Scribus finds fonts which Inkscape doesn't

Post about projects that involve using Inkscape and Scribus.
chraab
Posts: 10
Joined: Sun Mar 04, 2018 12:31 am

Scribus finds fonts which Inkscape doesn't

Postby chraab » Sat Apr 28, 2018 9:44 pm

Hi everyone,

I figured this might be a good place to ask this particular technical question. I'm using Inkscape 0.92.3 and Scribus 1.4.3. My issue is that I have OTF fonts (both bought and free) which are found and usable in Scribus, but not in Inkscape or LibreOffice. If someone knows a difference in libraries or tools used between Inkscape and Scribus, this might point us to a solution. I'm using Linux Mint 17.3, which is based on Ubuntu 14.04 Trusty.

Some more details: Generally it's not an entire font family, but certain styles, sometimes the majority of them. Refreshing the font cache (fc-cache -fv) shows these fonts being found. Examples of its output:

Code: Select all

/home/chris/.fonts/Fira_otf: caching, new cache contents: 35 fonts, 0 dirs
[...]
/home/chris/.fonts/KlinicSlab_Personal_License: caching, new cache contents: 8 fonts, 0 dirs
[...]


where 18 of 35 and 2 of 8 are found, respectively. You can download the first one here: https://bboxtype.com/downloads/Fira/Dow ... s_4301.zip
For example, Fira Sans Two, Four and Eight are among those not showing up. If you have a minute, I'd be grateful if you could test it for yourself.

Troubleshooting so far:

  • It's not the same as this because (Open/)LibreOffice doesn't find them, either. Besides, I'm not using Windows andthe FAQs say this was only a problem with very ancient versions, as in this other thread.
  • Refreshing the font cache, including with sudo privileges (as was suggested on the Mint forums) does nothing.
  • Both libotf and libotf-bin are installed.
  • Moving fonts from a user-specific to system-wide location does nothing. (Except the fonts being cached from the new location.)

User avatar
brynn
Posts: 9968
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Scribus finds fonts which Inkscape doesn't

Postby brynn » Sat Apr 28, 2018 10:39 pm

The only info in this current FAQ item (the wiki faq is no longer being updated....at least not for users - may be updated for developers, i.e. with highly technical info): https://inkscape.org/en/learn/faq/#some ... k-inkscape

The only other info I can provide, which may or may not be relevant for your particular problem is this. Inkscape can only use fonts which are installed on the system. Even though the font may reside in a system-wide directory, if it's not installed, Inkscape can't use it. As far as I understand, in some programs, you just have to install one font, and all the different variations of that font are available. But for Inkscape, each and every variation needs to be installed.

Full disclosure, fonts (and text in general) are not a strong point for me, so others may be able to provide additional info.

Moini
Posts: 2813
Joined: Mon Oct 05, 2015 10:44 am

Re: Scribus finds fonts which Inkscape doesn't

Postby Moini » Sat Apr 28, 2018 11:54 pm

It's a known issue that some font variants can't be found. Inkscape has issues with Roboto, too, for example. It's supposed to get better with the next major version.

If you look for known issues, better look in the bug tracker:
https://bugs.launchpad.net/inkscape/+bug/1555109
https://bugs.launchpad.net/inkscape/+bug/1655512
https://bugs.launchpad.net/inkscape/+bug/1470878
https://bugs.launchpad.net/inkscape/+bug/1710709
https://bugs.launchpad.net/inkscape/+bug/165521
https://bugs.launchpad.net/inkscape/+bug/1694326

If you're using the Inkscape snap:
https://bugs.launchpad.net/inkscape/+bug/1655609
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

chraab
Posts: 10
Joined: Sun Mar 04, 2018 12:31 am

Re: Scribus finds fonts which Inkscape doesn't

Postby chraab » Sun Apr 29, 2018 12:42 am

Thanks for all the info! It's reassuring that this is a known issue, my bad for not checking the bugtracker. Of course I don't want to abuse this forum for bug reports! The reason I wrote in the first place was the fact that it is the same in LibreOffice, but not Scribus. To me that seemed like a hint that it might be an issue with some library, instead of one related to Inkscape itself. And Tavmjong does suggest in one of these bugreports that libpango is to blame. I should check what Scribus is linked against!

I had read the FAQ item, but thought quality issues were less likely to apply since these are fonts made by professionals that I paid money for. Of course it can't be excluded! I will see if editing the font-weight property in FontForge as suggested in bug 1555109 and by Tavmjong in bug 165521 does the trick.

User avatar
brynn
Posts: 9968
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Scribus finds fonts which Inkscape doesn't

Postby brynn » Mon Apr 30, 2018 2:23 am

Nice collection of bug reports, Moini! Should be helpful for others.


Return to “Inkscape & Scribus”

Who is online

Users browsing this forum: No registered users and 1 guest