Inkscape svg with png inside doesn't show png in Chrome

Post about projects that use Inkscape for web design.
bigEsmurf
Posts: 1
Joined: Fri Sep 14, 2012 9:56 pm

Inkscape svg with png inside doesn't show png in Chrome

Postby bigEsmurf » Fri Sep 14, 2012 10:03 pm

Hoi all,

I'm using an inkscape svg in a web application, but things seem to go wrong in Chrome. For some reason the png included in the svg doesn't show. When you then open the svg direcly, things seem fine... strangely enough, when you then go back to the html-page which has the svg in an <img> tag, the png shows!

I've set up a test at http://www.develicious.nl/svgtest/testsvg.html ... Does anybody know what is wrong?

User avatar
Grobe
Posts: 395
Joined: Tue Feb 02, 2010 2:20 am

Re: Inkscape svg with png inside doesn't show png in Chrome

Postby Grobe » Mon Sep 17, 2012 9:11 am

Hi. You're right. It doesn't work with Chrome. Tested it.

However it works just fine with Firefox. So that means that it is an issue concerning only Chrome.
:lol:

Jelle
Posts: 78
Joined: Sat Nov 06, 2010 11:25 am

Re: Inkscape svg with png inside doesn't show png in Chrome

Postby Jelle » Thu Dec 06, 2012 11:26 am

Hoi Grobe,

How about just linking the png rather than embedding it. If it then works it is a encoding bug in Chrome. Linking is better practice anyway for webdesign.

Cheers..

Jelle

User avatar
brynn
Posts: 9604
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape svg with png inside doesn't show png in Chrome

Postby brynn » Fri Dec 07, 2012 1:16 am

But with linking, don't you have to keep the imported images together with the SVG?

User avatar
Grobe
Posts: 395
Joined: Tue Feb 02, 2010 2:20 am

Re: Inkscape svg with png inside doesn't show png in Chrome

Postby Grobe » Fri Dec 07, 2012 5:42 am

brynn wrote:But with linking, don't you have to keep the imported images together with the SVG?

If you by "together with" mean in same folder, it's the oposite way.
:lol:

User avatar
brynn
Posts: 9604
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape svg with png inside doesn't show png in Chrome

Postby brynn » Fri Dec 07, 2012 6:53 am

Are you sure? I know that I've used linking in the past, and later moved the imported image to another folder. But then it won't show up in the Inksape file.

User avatar
Grobe
Posts: 395
Joined: Tue Feb 02, 2010 2:20 am

Re: Inkscape svg with png inside doesn't show png in Chrome

Postby Grobe » Sat Dec 08, 2012 6:36 am

brynn wrote:Are you sure? I know that I've used linking in the past, and later moved the imported image to another folder. But then it won't show up in the Inksape file.
Yes that is correct. The absolute path to a file will change when the file is moved or renamed, so then you need to change the reference in the svg file too.
:lol:


Return to “Inkscape & the Web”

Who is online

Users browsing this forum: No registered users and 1 guest