Inkscape 0.91 - Missing icons.

General discussions about Inkscape.
User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Inkscape 0.91 - Missing icons.

Postby ragstian » Sun Feb 01, 2015 10:00 am

Hi.

Using the new 0.91 Stable - I discovered some missing icons.
In the View - Wide mode the icons for Undo and Redo just shows the 'Missing Icon' symbol.

Image


In View - Default and View Custom the Preferences icon is missing.

Image
(Still trying to figure out what to name
this icon to get it to work. Help appreciated!
Stay tuned.)

I "patched" the icon file "stealing and modifying" from 'symbolic-icons'.

SVG Image

The 'patched' icon file: Icons.svg
Copy to and replace the icons.svg in your "installdir/share/icons/" directory.

Edit;
I have also taken the liberty to "fix" the "Unset" icon in the Fill and Stroke dialog, this was earlier
a question mark which I (and others) thought invoked "help".
The icon 's name is 'paint-unknown' which might explain the question-mark.
(If you copied the file before the edit - download again.)

Old Dialog;
Image

New Dialog:
Image

Good Luck
Ragnar
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

User avatar
brynn
Posts: 9604
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape 0.91 - Missing icons.

Postby brynn » Sun Feb 01, 2015 11:37 am

All known issues. Several bug reports already, but I'm not inclined to search them out. But you have the link to Launchpad (bug tracker), right?

(I filed a couple of them myself, when I tried pre2.)

User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Inkscape 0.91 - Missing icons.

Postby ragstian » Sun Feb 01, 2015 12:30 pm

Hi

brynn wrote:All known issues.


Sorry for the post then! At least I managed to "sort out" three out of four "Problem Icons".
Where can I upload the icons.svg file to be incorporated in next release?

Strange that these "known issues" does not get fixed as it's relatively "quick and easy"
compared to the "heavy programming" that takes place in the developers community.
Maybe we can join the programmers in the effort of "fixing" similar issues?
I would be more than happy to join!

RGDS
Ragnar
Last edited by ragstian on Sun Feb 01, 2015 12:41 pm, edited 1 time in total.
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

tylerdurden
Posts: 1816
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Inkscape 0.91 - Missing icons.

Postby tylerdurden » Sun Feb 01, 2015 12:36 pm

Also I seem to have a few duplicate entries in the icons field of the preferences menu:

Code: Select all

C:\Documents and Settings\XXXXX\.icons
  C:\Documents and Settings\XXXXX\Local Settings\Application Data\icons
  C:\Documents and Settings\All Users\Application Data\icons
  C:\Documents and Settings\All Users\Documents\icons
  C:\Program Files\Inkscape\share\icons
  C:\Program Files\Inkscape\share\icons
  C:\Program Files\Inkscape\share\icons
  C:\Documents and Settings\All Users\Application Data\pixmaps
  C:\Documents and Settings\All Users\Documents\pixmaps
  C:\Program Files\Inkscape\share\pixmaps
  C:\Program Files\Inkscape\share\pixmaps
  C:\Program Files\Inkscape\share\pixmaps
  C:\Documents and Settings\XXXXX\Local Settings\Application Data\inkscape\icons
  C:\Documents and Settings\All Users\Application Data\inkscape\icons
  C:\Documents and Settings\All Users\Documents\inkscape\icons
  C:\Program Files\Inkscape\share\inkscape\icons
  C:\Program Files\Inkscape\share\inkscape\icons
  C:\Documents and Settings\XXXXX\Application Data\inkscape\icons
  C:\Program Files\Inkscape\share\icons


Problem?
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Inkscape 0.91 - Missing icons.

Postby ragstian » Sun Feb 01, 2015 12:50 pm

Hi.

MIA = "Missing In Action" for all that's not into American acronyms!

In your settings the icons.svg can be found in your installation directory and in the user preferences directory.
I keep my icons.svg file in the install/share/icons directory only as there are chances for updates.

The file in your user directory will take precedence over the one in the install directory, delete or rename the one in the user directory.

If the icons does not show up after this "fix", download the file again as I had "too many fingers" editing it at one point!

RGDS
Ragnar
Last edited by ragstian on Sun Feb 01, 2015 1:27 pm, edited 2 times in total.
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

tylerdurden
Posts: 1816
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Inkscape 0.91 - Missing icons.

Postby tylerdurden » Sun Feb 01, 2015 1:00 pm

Thank you!

A dandy little icon.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

User avatar
brynn
Posts: 9604
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape 0.91 - Missing icons.

Postby brynn » Sun Feb 01, 2015 3:06 pm

Oh, no apologies needed.

I'm going to go ahead and post these reports, because they provide a little info, and since we already have another message about this, maybe it will help.

I think it's because of the devlibs, that it's not such an easy fix. I have no idea what devlibs is, but somehow it supplies the icons.

https://bugs.launchpad.net/inkscape/+bug/1372150 (not much helpful info here, except the devlib reference)
https://bugs.launchpad.net/inkscape/+bug/1372151 see ~suv's comment #1 in this report, for the other related bugs and brief explanation (depending on how much you want to read)

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape 0.91 - Missing icons.

Postby ~suv » Sun Feb 01, 2015 3:19 pm

The missing icons are a known issue and tracked in

User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Inkscape 0.91 - Missing icons.

Postby ragstian » Sun Feb 01, 2015 4:09 pm

Hi.

The icons are not missing after editing the icons.svg file, even in the "stock" icon set.
It's no wonder that the icons are "missing" if they are not in the icons.svg file! Or am I missing something.
They work like a charm with my edited icons.svg file as seen here:
Image

RGDS
Ragnar
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape 0.91 - Missing icons.

Postby ~suv » Sun Feb 01, 2015 5:12 pm

ragstian wrote:It's no wonder that the icons are "missing" if they are not in the icons.svg file! Or am I missing something.
So you have a patch to fix the auto-selection of the correct directional icon versions for RTL languages?

(No, the bug is not that the icons are not in Inkscape's icons.svg file.)

User avatar
brynn
Posts: 9604
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape 0.91 - Missing icons.

Postby brynn » Sun Feb 01, 2015 5:25 pm

~suv wrote:
ragstian wrote:It's no wonder that the icons are "missing" if they are not in the icons.svg file! Or am I missing something.
So you have a patch to fix the auto-selection of the correct directional icon versions for RTL languages?

(No, the bug is not that the icons are not in Inkscape's icons.svg file.)


As I said, not so easy fix :mrgreen:

User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Inkscape 0.91 - Missing icons.

Postby ragstian » Sun Feb 01, 2015 5:32 pm

Hi.

Shame on me for thirty days! :oops:
Why would just these two icons need to be treated differently from others for Right To Left languages?
Are they supposed to be flipped horizontally?
Are the delete key arrow pointing to the left on those keyboards?

( It's better to fail having tried than not to try at all - I also proved that "a little knowledge is dangerous!" :D )

One thing puzzles me, why does the icons show when they are included in the icons.svg file if they are supposed to be "hard-wired" in the code?

RGDS
Ragnar
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

Janne
Posts: 228
Joined: Wed Oct 29, 2014 4:15 am

Re: Inkscape 0.91 - Missing icons.

Postby Janne » Mon Feb 02, 2015 10:53 am

Just for the record - I'm missing something too.

tylerdurden
Posts: 1816
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Inkscape 0.91 - Missing icons.

Postby tylerdurden » Mon Feb 02, 2015 11:16 am

Janne wrote:Just for the record - I'm missing something too.


Please see Ragnar's first post, you can download his repaired file and get three icons fixed.
The 'patched' icon file: Icons.svg https://www.dropbox.com/s/k3bxhesberr4p ... s.svg?dl=1
Copy to and replace the icons.svg in your "installdir/share/icons/" directory.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

Janne
Posts: 228
Joined: Wed Oct 29, 2014 4:15 am

Re: Inkscape 0.91 - Missing icons.

Postby Janne » Mon Feb 02, 2015 11:32 am

Thank you, Tylerdurden ( and Ragnar ) - I'll try :) I believe I just have to replace Ragnar's file with the existing one :)

Janne
Posts: 228
Joined: Wed Oct 29, 2014 4:15 am

Re: Inkscape 0.91 - Missing icons.

Postby Janne » Mon Feb 02, 2015 11:38 am

It fixed two of them but not this last one :)

User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Inkscape 0.91 - Missing icons.

Postby ragstian » Mon Feb 02, 2015 12:43 pm

Hi

Janne, if you look at my first post in this thread I stated that I had problems finding a named Icon for the one missing. Still looking.
According to ~suv this is NOT the right way to fix the problem. If you use my file the "sky might fall down" - or even worse.
The missing icon might be "hardwired" in the Inkscape code and not being user "fixable".

My fix is a "kludge" - use at your own risk.

RGDS
Ragnar
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

User avatar
brynn
Posts: 9604
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape 0.91 - Missing icons.

Postby brynn » Mon Feb 02, 2015 7:24 pm

Well, I can't answer your questions, Ragnar. My choice is just to have some missing icons, until the devs fix it. Clearly I don't understand enough to know what I'm doing, lol.

Even if you don't know what the missing icon is supposed to do, if you hover your mouse over it, some small text will pop up, telling you what it is or does. (It's called a "tool tip" on windows. Not sure what other systems call it.)

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape 0.91 - Missing icons.

Postby ~suv » Mon Feb 02, 2015 7:58 pm

ragstian wrote:Janne, if you look at my first post in this thread I stated that I had problems finding a named Icon for the one missing. Still looking.
Use the id "preferences-system" for the icon of the preferences dialog.
ragstian wrote:According to ~suv this is NOT the right way to fix the problem. If you use my file the "sky might fall down" - or even worse.
Nothing bad will happen (worst case: the user might make a mistake and replaces the installed (shared) icons.svg file with a broken or incorrectly downloaded file, then all icons will be missing -> reinstalling the software in this case will restore the original file).

Following instructions to install the modified icons.svg file as user icons file:

Code: Select all

%APPDATA%\inkscape\icons\icons.svg
is (IMvHO) better (since it reduces the risk of unintentionally modifying system files (or files installed by the application itself)).

(BTW - if intended to be installed as user icons file, you could provide a smaller file which only includes the additional icons, since icons not in the user icons file will be loaded from the installed (shared) one - by design).
ragstian wrote:The missing icon might be "hardwired" in the Inkscape code and not being user "fixable".

My fix is a "kludge" - use at your own risk.
Those "missing" icons should (and were) looked up and loaded as "stock" icons from a global desktop gtk icon theme (linux desktops) or from the built-in one (compiled into the Gtk+ toolkit libraries). Due to changes in the toolkit as well as in Inkscape this icon loading currently fails for a few of the stock icons. Adding them to Inkscape's icons.svg is a legit workaround (and works well for LTR languages for the directional icons), but doesn't address why it broke in the first place.

tylerdurden
Posts: 1816
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Inkscape 0.91 - Missing icons.

Postby tylerdurden » Tue Feb 03, 2015 12:08 am

~suv wrote:Use the id "preferences-system" for the icon of the preferences dialog.

Working now...

Thanks!
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

Janne
Posts: 228
Joined: Wed Oct 29, 2014 4:15 am

Re: Inkscape 0.91 - Missing icons.

Postby Janne » Tue Feb 03, 2015 2:35 am

Not working for me and I lost my color palette too - unsure if I will reinstall 0.91 or go back to 0.48 :)
Just uninstalled the version now .

Thank you, Ragnar, for your explanation :)

tylerdurden
Posts: 1816
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Inkscape 0.91 - Missing icons.

Postby tylerdurden » Tue Feb 03, 2015 2:50 am

Janne wrote:Not working for me and I lost my color palette too - unsure if I will reinstall 0.91 or go back to 0.48 :)
Just uninstalled the version now .


Hi Janne,

In order to use Ragnar's edited icons file, the file must be copied to the proper directory. That depends on your machine.

For the Preferences icon to work properly, the xml file needs to be updated with the ID of the icon object set to "preferences-system".

The missing palette may simply be setting the view: Menu: View>Show/Hide>Palette.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

Janne
Posts: 228
Joined: Wed Oct 29, 2014 4:15 am

Re: Inkscape 0.91 - Missing icons.

Postby Janne » Tue Feb 03, 2015 3:00 am

Thank you again, Tylerdurden - I'll install the 0.91 again now and then follow all the good instructions here :)

User avatar
ragstian
Posts: 1159
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Inkscape 0.91 - Missing icons.

Postby ragstian » Tue Feb 03, 2015 3:16 am

Hi.

Never would I have imagined that my initial post would result in this!

Messing with the icon-system in Inkscape is like "opening up a can of worms" or rather "a can of small snakes" as they bite!

Reading through the bug reports etc I have realized that the icon system is very much a system "under construction".
Some icons works well and renders nicely if the icon size is set to "smaller" in the "Interface" preferences dialog,
the same icon will become blurry and look like "not so nice" in "Small" or "Large" setting.
This due to the initial size in the icons.svg file and the "pixel alignment" of the
icon (and it's objects) in the same fie. A lot to learn here!

Suggestion to developers; Incorporate all the different size icons in the icons.svg file to get rid of "scaling artifacts".
I would be more than happy to create such a file based on the existing one.
Same for the icons that are different in the RTL (Right To Left) and LTR languages.

RGDS
Ragnar
Last edited by ragstian on Tue Feb 03, 2015 6:54 am, edited 2 times in total.
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

Janne
Posts: 228
Joined: Wed Oct 29, 2014 4:15 am

Re: Inkscape 0.91 - Missing icons.

Postby Janne » Tue Feb 03, 2015 4:15 am

Hi Ragnar - it's not 'your' fault that my colors disappeared ( see screen shot above ) - it was me messing up :D


Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 3 guests