MORPHOLOGY OUTLINE FILTER NOT WORKING

General discussions about Inkscape.
andreerader
Posts: 5
Joined: Mon Apr 11, 2016 2:27 pm

MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby andreerader » Mon Apr 11, 2016 2:57 pm

HI, Im using Inkscape 0.91 on Mac 0S 10.11.4 with XQuartz. The Morphology Outline Filter is not working. The first time I used the filter I could see an outline around the desired text selected when I selected LIVE PREVIEW. When I tried to change the settings for the filter to make the outline thicker the outline disappeared, and has not been visible since. When I hit LIVE PREVIEW the selection box around the object widens normally as if the outline is added, but nothing is there. I have checked all color options, opacity, etc. Everything appears correct. FILL IMAGE and HIDE IMAGE boxes work normally. I have used this filter hundreds of times on an older Mac, and never had any problems. This was the first time using Inkscape on this computer. I have reloaded the Inkscape & XQuartz app several times, and still no Outline. All the other filters work fine. Im stumped. Anyone have any ideas?

Thnx

User avatar
brynn
Posts: 9931
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby brynn » Mon Apr 11, 2016 5:18 pm

It's hard for us to guess what might have happened. But if you could provide an SVG file which contains that modified filter, we could look at it and figure out what happened.

Or you could just start over with the original filter, and try again.

Moini
Posts: 2769
Joined: Mon Oct 05, 2015 10:44 am

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby Moini » Tue Apr 12, 2016 3:23 am

Sometimes filters aren't removed in 0.91 when using the preview. Try if removing the filter via Filters -> Remove Filters does anything.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

andreerader
Posts: 5
Joined: Mon Apr 11, 2016 2:27 pm

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby andreerader » Wed Apr 13, 2016 12:36 pm

Thx, everyone for responding, but I think my problem is misunderstood. In short, the outline filter behaves like it is working correctly, but is not visible. Any further suggestions are appreciated. I will provide a sample SVG shortly.

andreerader
Posts: 5
Joined: Mon Apr 11, 2016 2:27 pm

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby andreerader » Wed Apr 13, 2016 12:57 pm

Here is a sample of text with Outline filter added, but not visible. Thx everyone!
Attachments
OUTLINE FILTER SAMPLE.svg
outline filter added but not visible
(4.38 KiB) Downloaded 45 times

User avatar
brynn
Posts: 9931
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby brynn » Wed Apr 13, 2016 1:37 pm

Mac? You're on a Mac?! Isn't cleversomeday also on a Mac? Some new issue with Macs and filters not showing up?

Have there been any very recent upgrades to many or most Mac systems?

cleversomeday
Posts: 58
Joined: Tue Jan 19, 2010 6:52 am

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby cleversomeday » Fri Apr 15, 2016 4:40 am

I am on an older Mac, but it still might be worth starting from a different template (A4 vs Letter, for example) to see if that makes any difference, as it does in my case.

User avatar
brynn
Posts: 9931
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby brynn » Fri Apr 15, 2016 7:34 am

I've tested the Morphology > Outline filter using the template which was causing a similar problem in another topic. I'm not sure whether that template affects this filter or not. There seems to be some kind of problem with the Live Preview, for sure.

In the template from the other topic, the filter creates a black rectangle over top of my test rectangle, using Live Preview. None of the options make any change in the black rectangle. I thought it might be a very thick outline, but I can't seem to make it thinner, or change it at all. But if I don't use the preview, and I just click Apply, nothing happens.

In my own default template, the only kind of display I can get, is if I check Fill Image. However, there are a lot of options in the filter dialog. Maybe I just haven't found the right combination. Can someone give a configuration of options that produces some kind of outline? It doesn't matter whether I use Live Preview, or just click Apply. No outline ever appears.

One problem that probably should be reported, is when you click Live Preview, it actually applies the filter -- according to the status bar, although there's no visible change to the object. There appears to be other problems with this filter as well!

Ok, I've made a bug report: https://bugs.launchpad.net/inkscape/+bug/1570601

Also, andreerader, are you using any kind of custom template?

andreerader
Posts: 5
Joined: Mon Apr 11, 2016 2:27 pm

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby andreerader » Wed Mar 07, 2018 11:34 am

Well, been a long while, I just gave up on the Outline Filter in Incscape, still having same problem on different Mac. Did anyone ever figure this out? It worked on this Mac, until I changed the outline thickness, then same problem as mentioned earlier, can't see outline.

andreerader
Posts: 5
Joined: Mon Apr 11, 2016 2:27 pm

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby andreerader » Wed Mar 07, 2018 11:34 am

And I'm not using a custom template.

Moini
Posts: 2769
Joined: Mon Oct 05, 2015 10:44 am

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby Moini » Wed Mar 07, 2018 11:33 pm

So you're using a different version now, and started with a blank canvas?
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

Lazur
Posts: 4575
Joined: Tue Jun 14, 2016 10:38 am

Re: MORPHOLOGY OUTLINE FILTER NOT WORKING

Postby Lazur » Thu Mar 08, 2018 6:41 am

Chrome doesn't render outlines in the attached svg so I suppose you saw it working on a previous inkscape version's pre cairo renderer -probably the filter is outdated -it has not much to do with the operating system.

Attaching two filters drawing outlines -one is drawing a 1 px wide stroke regardless the zoom level, the other is scalable.
OUTLINE FILTER SAMPLE2.svg
(6.79 KiB) Downloaded 26 times


Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 2 guests