[SOLVED] Building Inkscape on OpenSUSE

General discussions about Inkscape.
ChameleonScales
Posts: 10
Joined: Sat Jan 07, 2017 8:39 pm

[SOLVED] Building Inkscape on OpenSUSE

Postby ChameleonScales » Sat Mar 18, 2017 1:16 pm

Hi,
First, I'm not sure this is the best place to post this so if you know a better one, please tell me.

I'm trying to build a bugfix version of Inkscape on OpenSUSE but I'm a bit stuck.

I followed the instructions here but when I run "cmake .." I get this :

Code: Select all

------------------------------
Building Makefile for Inkscape
------------------------------
Source Dir: /home/caetano/Downloads/~inkscape.dev/inkscape/trunk
Binary Dir: /home/caetano/Downloads/~inkscape.dev/inkscape/trunk/build
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.28")
-- Creating build files in: /home/caetano/Downloads/~inkscape.dev/inkscape/trunk/build
-- The C compiler identification is GNU 4.8.5
-- The CXX compiler identification is GNU 4.8.5
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Creating build files in: /home/caetano/Downloads/~inkscape.dev/inkscape/trunk/build
-- Checking for modules 'harfbuzz;pangocairo;pangoft2;fontconfig;gthread-2.0;gsl;gmodule-2.0'
--   Found harfbuzz, version 1.4.2
--   Found pangocairo, version 1.40.1
--   Found pangoft2, version 1.40.1
--   Found fontconfig, version 2.11.1
--   Found gthread-2.0, version 2.48.2
--   Found gsl, version 1.16
--   Found gmodule-2.0, version 2.48.2
-- Checking for module 'x11'
--   Found x11, version 1.6.3
-- Checking for module 'gnome-vfs-2.0'
--   Found gnome-vfs-2.0, version 2.24.4
-- Found GnomeVFS2: /usr/lib64/libgnomevfs-2.so
-- Found LCMS2: /usr/lib64/liblcms2.so 
-- Performing Test ICONV_SECOND_ARGUMENT_IS_CONST
-- Performing Test ICONV_SECOND_ARGUMENT_IS_CONST - Failed
-- Found Iconv: /usr/lib64/libc.so
-- Found Intl: /usr/include 
-- Found BoehmGC: /usr/local/lib64/libgc.so
-- Checking for module 'poppler'
--   Found poppler, version 0.43.0
-- Found poppler: /usr/lib64/libpoppler.so
-- Checking for module 'poppler-glib'
--   Found poppler-glib, version 0.43.0
-- Found poppler-glib: /usr/lib64/libpoppler-glib.so
-- Checking for module 'cairo-svg'
--   Found cairo-svg, version 1.15.2
-- Found cairo-svg: /usr/lib64/libcairo.so
-- Checking for module 'poppler-cairo'
--   Found poppler-cairo, version 0.43.0
-- Found poppler-cairo: /usr/lib64/libcairo.so
-- Checking for module 'libwpg-0.3'
--   Found libwpg-0.3, version 0.3.0
-- Found libwpg-0.3: /usr/lib64/libwpg-0.3.so
-- Checking for module 'librevenge-0.0'
--   Found librevenge-0.0, version 0.0.2
-- Found librevenge-0.0: /usr/lib64/librevenge-0.0.so
-- Checking for module 'librevenge-stream-0.0'
--   Found librevenge-stream-0.0, version 0.0.2
-- Found librevenge-stream-0.0: /usr/lib64/librevenge-stream-0.0.so
-- Checking for module 'libvisio-0.1'
--   Found libvisio-0.1, version 0.1.5
-- Found libvisio-0.1: /usr/lib64/libvisio-0.1.so
-- Checking for module 'libcdr-0.1'
--   Found libcdr-0.1, version 0.1.3
-- Found libcdr-0.1: /usr/lib64/libcdr-0.1.so
-- Found JPEG: /usr/lib64/libjpeg.so 
-- Found ZLIB: /usr/lib64/libz.so (found version "1.2.8")
-- Found PNG: /usr/lib64/libpng.so (found version "1.6.8")
-- Checking for module 'popt'
--   Found popt, version 1.16
-- Found Popt: /usr/lib64/libpopt.so
-- Found Potrace: /usr/lib64/libpotrace.so
-- Checking for modules 'gtkmm-3.0>=3.8;gdkmm-3.0>=3.8;gtk+-3.0>=3.8;gdk-3.0>=3.8;gdl-3.0>=3.4'
--   
--   
--   
--   
--   
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:363 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:528 (_pkg_check_modules_internal)
  CMakeScripts/DefineDependsandFlags.cmake:253 (pkg_check_modules)
  CMakeLists.txt:89 (include)


-- Configuring incomplete, errors occurred!
See also "/home/caetano/Downloads/~inkscape.dev/inkscape/trunk/build/CMakeFiles/CMakeOutput.log".
See also "/home/caetano/Downloads/~inkscape.dev/inkscape/trunk/build/CMakeFiles/CMakeError.log".


I don't know which package is missing or what went wrong.

Thanks in advance.
Last edited by ChameleonScales on Sun Mar 19, 2017 9:27 am, edited 1 time in total.

User avatar
brynn
Posts: 9905
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Building Inkscape on OpenSUSE

Postby brynn » Sat Mar 18, 2017 5:14 pm

You're probably better off posting either on the developer mailing list or developer IRC. https://inkscape.org/en/community/ Possibly searching the mailing list archives might find it already discussed. https://sourceforge.net/p/inkscape/mail ... ape-devel/ Or maybe parts of it discussed, and you can find a helpful tip.

I don't know if any bug reports have been filed about it or not, but you could try searching Launchpad as well https://launchpad.net/inkscape

Moini
Posts: 2725
Joined: Mon Oct 05, 2015 10:44 am

Re: Building Inkscape on OpenSUSE

Postby Moini » Sat Mar 18, 2017 10:20 pm

Hi Caetano,

the version you're trying to install is not a 'bugfix version' but trunk. It's the development version that often introduces bugs, and isn't deemed stable. It requires gtk3, which it seems you don't have installed.

You would (at least, probably more) need libgtkmm-3.0-dev, libgdl-3-dev and other gtk3 development libraries.

To find out which ones are available, do a search on the command line like this:

Code: Select all

zypper se package_name_or_part_of_name


Then install the ones that fit with the version number (i.e. 3) and have a -dev at the end.

Repeat this for each package that the compiler says is missing.

But if you're looking for a bugfix version for 0.92.1, please get the sources from https://code.launchpad.net/~inkscape.de ... ape/0.92.x
Of course, depending on the bug you're trying to work around, the fix may or may not be available in the stable branch.
This one does not require gtk3 and should compile right away.

Which bug are you trying to circumvent?
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

ChameleonScales
Posts: 10
Joined: Sat Jan 07, 2017 8:39 pm

Re: Building Inkscape on OpenSUSE

Postby ChameleonScales » Sun Mar 19, 2017 2:08 am

Thank you very much. I guess gtkmm3-devel is the openSUSE name corresponding to libgtkmm-3.0-dev and gdl-devel is the corresponding name to libgdl-3-dev because it worked ! And now I see where the terminal told me what was missing.
Also you're right it's the trunk version that I wanted. I'm not very familiar with the terminology yet. I thought I could call it a bugfix version because it was a commit that fixed a bug with the plain svg export for Inkscape 0.93. I could test it and it seems the bug fix worked too !
Also thanks brynn for this advice.

Moini
Posts: 2725
Joined: Mon Oct 05, 2015 10:44 am

Re: Building Inkscape on OpenSUSE

Postby Moini » Sun Mar 19, 2017 8:43 am

:-D Glad it worked (I've never used openSUSE and had to look up the zypper command ;-) )
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 1 guest