Page 1 of 1

Missing font

Posted: Fri Aug 24, 2018 1:44 pm
by jkayeh
I am struggling with a missing font that does not show up on my list in inkscape. I've read countless similar posts and been pointed to "bugfixes" but I am not sure how to solve the problem. The font is an opentype, saved on my system, unzipped folder, saved in windows font. I am able to use this font in all other programs on my computer. I have uninstalled, reinstalled, open and closed program, turned off/on computer. I have only been using inkscape for the past couple of months so I'm still learning. And I am no computer expert but I know some.

Re: Missing font

Posted: Fri Aug 24, 2018 8:37 pm
by Moini
Not much you can do about it, currently. You could try if it works in the development version of Inkscape, which you can get from here:
https://inkscape.org/releases/master/

Make sure to make a backup of your current preferences file before you run the development version. Preferences files are not backwards compatible.

Re: Missing font

Posted: Sat Aug 25, 2018 12:13 am
by tylerdurden
Might not work in Inkscape regardless of version.

AIUI, Inkscape only will recognize fonts styled with CSS conventions.

Since Inkscape uses SVG as its native file format, we need to take a quick look at how SVG describes font faces. SVG 1.1 (which for fonts is basically the same as CSS 2.1 ) defines the following font-selection properties:
font-family.
font-style: normal, italic, oblique.
font-variant: normal, small-caps.
font-weight: normal, bold, bolder, lighter, 100, 200, 300, 400, 500, 600, 700, 800, 900.
font-stretch: normal, wider, narrower, ultra-condensed, extra-condensed, condensed, semi-condensed, semi-expanded, expanded, extra-expanded, ultra-expanded.

...Also, SVG and CSS have no way to distinguish between two faces in the same font-family that differ in away not described by the above properties (e.g. Pochoir Regular and Pochoir Sprayed).
http://tavmjong.free.fr/blog/?p=822

Renaming the "Preferred Family" to match the font family name using FontForge makes the font usable in Inkscape.
Image

Re: Missing font

Posted: Sat Aug 25, 2018 3:22 am
by jkayeh
Looks like I'm off to learn how to use FontForge . . . . Thanks for the fix!

Re: Missing font

Posted: Sat Aug 25, 2018 7:49 am
by cleversomeday
My workaround is to use Font Lab Pad to generate a quick SVG, but if you want to rename fonts, here's a good tutorial http://themissy.com/2018/font-tutorial- ... ganization

Re: Missing font

Posted: Sat Aug 25, 2018 1:13 pm
by jkayeh
I followed tutorials on how to change the name and "family" then finally figured out how to generate and save it properly. But now I get this . . . .
font.JPG
font.JPG (115.42 KiB) Viewed 5712 times

What did I do wrong now?

Re: Missing font

Posted: Sun Aug 26, 2018 2:59 am
by tylerdurden
I can't say what exactly went wrong there, but I'd simply use that font (regular) as it was (from the source). The sans version was the original problem and it does not seem to have the kerning problem the regular version has after processing with FF.

Re: Missing font

Posted: Mon Aug 12, 2019 1:35 am
by Chrisjan.j
The easiest solution is to right click on the font when installing, and selecting "install for all users" - rather than double clicking the font to install (which only installs for the active user).

You should be able to install a font for all users even though it is already installed for the current user.

Restart Incskape once the font is installed for all users, and it should work fine.

Re: Missing font

Posted: Sun Aug 25, 2019 5:53 pm
by Dzsulia
You are the best, Chrisjan.j! Thank you for posting your reply, it was the easiest and best solution! :) Worked fine for me!

Re: Missing font

Posted: Tue Aug 27, 2019 10:50 am
by Moini
(Just to clarify: the last two posts here refer to a different issue than the original thread, more info can be found at https://gitlab.com/inkscape/inkscape/issues/50 )