Problem Opening DXF

General discussions about Inkscape.
Posts: 1
Joined: Tue Nov 20, 2018 7:36 am

Problem Opening DXF

Postby Domenech » Tue Nov 20, 2018 7:43 am

Hello, i am not expert at all using Inkscape but I always follow the same path to get my DxF data from Dwgs in Autocad in order to get the Gcode for my laser. I have repeated this operation 50 times before with different data, but in a certain one I get this description and I can not open the data.

"Traceback (most recent call last):

File "", line 443, in <module>

w = 90.0/25.4*vals[groups['370']][0]/00.0

ZeroDivisionError: float division"

I have tried all I can now, exporting in a different version, from different programmes, putting all lines in 0 level, exporting like polylines, like lines.

Also, I don't know how to get the "line 443" and smash it...

some can bring some light on it?

PD: I have already tried to find similar stuff in the forum but never this problem...

Posts: 696
Joined: Wed Jan 13, 2010 4:36 am

Re: Problem Opening DXF

Postby v1nce » Tue Nov 20, 2018 8:35 am

Which operating system ?
Which version of inkscape ?

Look for a file named "" somewhere on your drive.
It seems that this file (=program) has been altered.

You should be able to edit this file with any (decent) text editor.
(You probably should avoid notepad)

it -probably- should be w = 90.0/25.4*vals[groups['370']][0]/100.0 and not 00.0
(I'm not sure you're running the last version of dxf_input ; I saw other versions that seem more recent and that use 96 (dpi) instead of 90 (dpi))

Reinstall inkscape should probably fix this too (unless it is in an extension you install by hand)

Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 6 guests