Page 1 of 1

Re: Paths are linking while using the warp tool.

Posted: Wed Aug 07, 2019 11:58 am
by Moini
Mmh. Aside from this probably being a bug - maybe one that can't easily be fixed, but still a bug, that you should report at https://inkscape.org/report , I would suggest you use (any one of) the following, more common options to fix up your paths:

1. Path > Simplify
2. Path > Path effects > Simplify
3. In the settings for the tool at the top, already add a certain level of smoothing before you start drawing
4. use the node tool to smoothe your lines manually
5. change the node type to anything of the following types: smooth, symmetrical, auto-smooth (select all nodes that you want to smooth for that)
6. when drawing your shapes with the Bézier tool, select a different mode, e.g. Spiro
7. when drawing your shapes with the Bézier tool, try out the click and drag variant of drawing a Bézier path

Re: Paths are linking while using the warp tool.

Posted: Tue Aug 13, 2019 7:58 am
by Xav
NOTE: The original post was edited to include a spam link. So that Moini's reply might still be useful to someone, here's the link-free post that was originally in this topic:

I'm using a mouse and not a tablet so my go-to method of drawing lines is to draw a path then smooth it/push it into place with the warp tool ("push parts of paths in any direction"), but when I do it links the ends of the path. I've tried a few settings variations but nothing seems to fix the problem. I actually had a similar issue at one point with illustrator so I'm guessing this is a side effect of some feature inherent to vectors.

Does anyone know how to disable whatever it is that's making this happen?

Re: Paths are linking while using the warp tool.

Posted: Tue Aug 13, 2019 10:32 pm
by Moini
Thanks, Xav. I was a bit surprised to see a thread started by myself :)