fantastically old lxml problem

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
jsfak
Posts: 1
Joined: Wed Aug 15, 2012 2:06 am

fantastically old lxml problem

Postby jsfak » Wed Aug 15, 2012 2:30 am

Each time I try to use Jessyink or Sozi I get the error stating the fantastic lxml wrapper for libxml2 is required by inkex.py but it can't be found.

I've read the FAQs and the plethora of posts and suggestions for correcting this problem. Though, I'm not sure that many people use Inkscape for Windows XP anymore or the problem is more prevalent in Macs, as most of the posts refer to OSX.

I've tried installing the xml packages using executables and easy_install and from different sources. However, my system is not connected to the internet so I have not had easy_install search for the package itself. I've reinstalled Inkscape and used it with the supplied Python, Python27, and Python26, each time with a cleanup and fresh install and sometimes just a dirty copy and paste. I've also modified the PythoPATH.

I have not deleted or modified the preferences.xml file as I cannot find it in the current versions.

Can someone of knowledge help me correct this problem? It seems to have been around for a very long time. There seem to be lots of suggestions without a single fix-all. Yet, there is a sudden dropoff in discussion about the topic so I wondered if I missed something. I would appreciate some help here.

jayh
Posts: 6
Joined: Thu Dec 25, 2014 7:21 pm

Re: fantastically old lxml problem

Postby jayh » Sat Dec 27, 2014 3:34 pm

having this same problem when i try to use most (any?) of the Extensions in Inkscape 0.48.4 r9939 (Linux Mint 17 Qiana, Python 2.7.6), not at all clear if or what the solution is.

searched around, found a lot of "maybe yes/maybe no" proposals for MacOS but not at all confident that they'd apply.

hoping some knowledgable persons hereabout can enlighten me.

ftr the full text of the error message is:
The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension. Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml

jayh
Posts: 6
Joined: Thu Dec 25, 2014 7:21 pm

Re: fantastically old lxml problem

Postby jayh » Tue Dec 30, 2014 6:23 am

*bump*

no suggestions?

Lazur
Posts: 4599
Joined: Tue Jun 14, 2016 10:38 am

Re: fantastically old lxml problem

Postby Lazur » Tue Dec 30, 2014 1:03 pm

Can only suggest to either report a bug at launchpad or join the conversation at the live chat board.
Developers may tell you what's going on.

jayh
Posts: 6
Joined: Thu Dec 25, 2014 7:21 pm

Re: fantastically old lxml problem

Postby jayh » Tue Dec 30, 2014 3:04 pm

fair enough. since this issue has obviously been around for years i had hoped/expected there would be a more direct solution to the problem. if not so be it.

fwiw it seems the issue has been ongoing since 2009. see "Extensions won't run, give lxml error" at bugs.launchpad.net/inkscape/+bug/450927

later: the following seems to have solved the problem ..
sudo apt-get install python-lxml

kugela
Posts: 1
Joined: Mon Mar 23, 2015 6:59 am

Re: fantastically old lxml problem

Postby kugela » Mon Mar 23, 2015 11:41 am

Hi all,

After spending a good portion of the day trying to find an adequate and/or definitive solution to the fantastically old lxml problem, I wanted to post my solution in hopes of saving others the headache.

My situation:
Windows 7
Inkscape 0.91 64-bit
Separate Python 3.3 installation (prior to inkscape)

My solution:
The only fix for Windows that I could find online suggested deleting the PYTHONHOME environment variable, but since I had to manually set PYTHONHOME to get Python 3.3 to work, I wasn't going to do that. After some trial-and-error, I found that all I had to do was add "C:\Program Files\Inkscape\python\Lib\site-packages" to the end of the system-level PYTHONPATH variable and restart Inkscape - simple as that. I didn't test to see whether the path has to be added to the end of PYTHONPATH. The order shouldn't matter, but when something works, I tend to keep everything the same regardless if it matters. Also, I'm not sure if it has to be system-level PYTHONPATH. I only have it at the system level, but again, it shouldn't matter if you have it at the user level, or both.

Here is a step-by-step for Windows 7:
  1. Open the Start menu.
  2. Right-click "Computer" and select "Properties". Alternately, you could do this from an explorer window instead of Start, or you could open the control panel, select "System and Security", and then "System".
  3. Next, select "Advanced system settings" in the far left panel of the "System" window. You need Administrator privileges to do this.
  4. You should then get the "System Properties" dialog box with the "Advanced" tab selected. At the bottom, just above the cancel button, you should see the "Environment Variables..." button. Click it.
  5. There should be 2 lists of variables: user on top, system on the bottom. Find and select PYTHONPATH in the system list. Click "Edit..."
  6. Don't delete what's there, just go to the end of the "Variable value". Add a semicolon to the end if it doesn't already have one, then type "Inkscape path\python\Lib\site-packages". For me, it's "C:\Program Files\Inkscape\python\Lib\site-packages". If you're running 32-bit Inkscape, it's probably in "Program Files (x86)".

    • If you don't have a PYTHONPATH variable, click the "New..." button (the one under the system list). Enter "PYTHONPATH" for the name and your site-packages path for the variable value.
  7. Click OK, then OK, then OK.
  8. Open Inkscape, and you should be good. If Inkscape was already open, restart it. <- IMPORTANT

That's what worked for me. I hope it works for anyone who happens upon this. I'm not sure if my solution applies to versions other than 0.91 64-bit, but I think there's a good chance. If it doesn't, one possibility is that your lxml library may have been deleted or corrupted. It might be a good time to uninstall Inkscape and then install the the latest version. Heck, they might even have this problem fixed soon.

Good Luck!

elecman
Posts: 27
Joined: Mon Feb 09, 2015 1:39 pm

Re: fantastically old lxml problem

Postby elecman » Fri Oct 20, 2017 11:00 am

That didn't work for me (inkscape 0.92.2) but uninstalling all inkscape versions, then re-installing the latest version did work. Some more solutions here:

https://stackoverflow.com/questions/417 ... scape-0-92

User avatar
brynn
Posts: 10052
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: fantastically old lxml problem

Postby brynn » Mon Oct 23, 2017 12:06 am



Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 28 guests