Page 1 of 1

Shortcut Alt+D not working in 0.92.1

Posted: Thu Apr 27, 2017 9:09 pm
by theozh
It seems that the shortcut for cloning Alt+D doesn't work in Inkscape 0.92.1 r15371 Win7/64 and Win10
But it does work in IS 0.91 r13725 Win7/64
Is there maybe a config file to check or set these shortcuts?

edit:
well, when I open a new empty file it doesn't work. If I modify an old file it seems to work. Strange!
Are shortcuts Document properties???

edit2:
OK, I think I found it:
1. Draw an object
2. Press Shift+Ctrl+O
3. Select your object
4. Press Alt+D no clone is created!
Seems pretty buggish to me... Can others reproduce this?

Re: Shortcut Alt+D not working in 0.92.1

Posted: Thu Apr 27, 2017 9:49 pm
by tylerdurden
Works as it should here... 0.92.1 r15371 Win8/64.

Re: Shortcut Alt+D not working in 0.92.1

Posted: Thu Apr 27, 2017 11:43 pm
by brynn
I find that Alt D does not work with Object Properties dialog open.

Windows 7 Pro, 64-bit, Inkscape 0.92.1, 64-bit, exe installer

Seems buggish to me too. I found this one: https://bugs.launchpad.net/inkscape/+bug/1671947

Re: Shortcut Alt+D not working in 0.92.1

Posted: Fri Apr 28, 2017 12:54 am
by theozh
Thanks @brynn for checking. Yes, that seems to be the same thing.
Actually, it's not working with IS 0.91 r13725...
If the Object dialog or the PNG export dialog (maybe others) are open Alt+D does not work.
OK, let's subscribe to the bug report and hope that it will be fixed soon.

Re: Shortcut Alt+D not working in 0.92.1

Posted: Fri Apr 28, 2017 12:56 am
by tylerdurden
I had my dialog floating, which seems to behave differently... When docked, the panel interferes.

Re: Shortcut Alt+D not working in 0.92.1

Posted: Fri Apr 28, 2017 1:20 am
by brynn
If you find details which seem important, that aren't in the bug reports, it would be helpful if you could add them in a new Comment.