Error "printemf::begin at EMRHEADER" when attempting to copy an object

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
toxigames
Posts: 141
Joined: Sat Aug 17, 2013 7:28 pm

Error "printemf::begin at EMRHEADER" when attempting to copy an object

Postby toxigames » Thu Jun 08, 2017 7:00 pm

From time to time I get this weird error (see screenshot attached) when attempting to copy an object. The only fix I have found is to restart my PC. Restarting Inkscape, loading another document, loading a new document... none of it works. Only restarting my computer works. From memory this probably happens once every 14th day, and I use my computer every day (opening it a the beginning at the day, closing it at evening). So not a very frequent error, but annoying nonetheless. Luckily Inkscape catches the error and autosaves a copy of the document before exiting.

Does anyone know anything about this error? Why does it happen when trying to copy something? Why do I need to reboot my computer when this happen? (is it perhaps actually an error in my Windows that prevents Inkscape from working, and only a reboot sets whatever is wrong right? If so, what is that all about?)

Additional info: I tried googling the error and others have had the error too, but their cause descriptions deviate from what I experience (for me the error does not seem tied to the document, but to some unknown issue that persists until rebooting Windows).
Attachments
Inkscape_error_emrHeader.png
Inkscape_error_emrHeader.png (3.84 KiB) Viewed 597 times

Moini
Posts: 2213
Joined: Mon Oct 05, 2015 10:44 am

Re: Error "printemf::begin at EMRHEADER" when attempting to copy an object

Postby Moini » Fri Jun 09, 2017 10:29 am

Can you test the fix version in the bug tracker, perhaps?

https://bugs.launchpad.net/inkscape/+bug/1661593

jazzynico asked for someone to test, but hasn't gotten a reply since February.

Also related:
https://bugs.launchpad.net/inkscape/+bug/1615216

Please add your info to the bug reports, the devs will be glad to get more info.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

toxigames
Posts: 141
Joined: Sat Aug 17, 2013 7:28 pm

Re: Error "printemf::begin at EMRHEADER" when attempting to copy an object

Postby toxigames » Mon Jun 12, 2017 3:59 am

Moini wrote:Can you test the fix version in the bug tracker, perhaps?

https://bugs.launchpad.net/inkscape/+bug/1661593

jazzynico asked for someone to test, but hasn't gotten a reply since February.

I could but.... seeing as the error happens on average every 14 days (but could take longer, sometimes it's a week, sometimes a month etc), it could be a very long time to be sure that it's fixed or not. If no error happens for a whole month that could just be I'm being (un)lucky that I didn't encounter it yet. Add to that that I don't like 0.92, there's too many bad changes (imo) and a few bugs that wasn't present in 0.91, so I would hate having to use 0.92 for months just to hunt down this bug. I guess it has to be more frequent/severe for me to warrant such a prolonged test.

Moini wrote:Also related:
https://bugs.launchpad.net/inkscape/+bug/1615216

Please add your info to the bug reports, the devs will be glad to get more info.

Ok I'll look into doing that :)

Moini
Posts: 2213
Joined: Mon Oct 05, 2015 10:44 am

Re: Error "printemf::begin at EMRHEADER" when attempting to copy an object

Postby Moini » Mon Jun 12, 2017 7:42 am

Thanks, toxigames :)
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 1 guest