Installed Fonts not found in Inkscape 0.92.3

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
Clero
Posts: 1
Joined: Mon Oct 15, 2018 6:28 pm

Installed Fonts not found in Inkscape 0.92.3

Postby Clero » Mon Oct 15, 2018 6:34 pm

Hello together ... I have a problem:
.
to create a logo, I installed the font Forgotten Futurist in Windows 10 (Pro/64bit). This works fine in Win10 by simply double clicking on the .ttf file, in my case "forgotten_futurist_rg.ttf". The font will then install itself automatically.

The font is then displayed in the Windows font settings: http://prntscr.com/l66v6y


The above mentioned font is now available in all applications ... except in Inkscape (version 0.92.3) ^^

I have also tried to clear the font cache from Windows 10 several times - following instructions like this: https://www.it-administrator.de/themen/ ... 66729.html

Unfortunately nothing works ... what am I doing wrong here? It would be great if someone could give me a tip! :)

Translated with http://www.DeepL.com/Translator

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hallo Zusammen ... ich habe da ein Problem:

um ein Logo zu kreieren, habe ich die Schriftart Forgotten Futurist in Windows 10 (Pro/64bit) nachinstalliert. Das funktioniert in Win10 ja wunderbar, indem man einfach einen Doppelklick auf die .ttf-Datei, in meinem Fall "forgotten_futurist_rg.ttf" macht. Die Schriftart installiert sich dann automatisch.

Die Schriftart wird dann in den Windows Schriftarteneinstellungen angezeigt: http://prntscr.com/l66v6y


Die oben genannte Schriftart steht mir nun in allen Anwendungen zur Verfügung ... außer in Inkscape (Version 0.92.3) ^^

Ich habe auch schon mehrfach versucht den Font-Cache von Windows 10 zu löschen - nach Anleitungen wie dieser hier: https://www.it-administrator.de/themen/ ... 66729.html

Leider klappt nichts ... was mache ich hier falsch? Es wäre großartig, wenn mir jemand einen Tipp geben könnte! :)

VG
Alex

User avatar
brynn
Posts: 10104
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Installed Fonts not found in Inkscape 0.92.3

Postby brynn » Mon Oct 15, 2018 9:12 pm

Inkscape needs to be closed when you install new fonts. Well, it doesn't have to be closed, but the font won't show up until you close and re-open Inkscape.

If you've already closed and re-opened Inkscape by now, and you still have the same problem - If that's a free font, could you share a download link, so we can test?

Moini
Posts: 2955
Joined: Mon Oct 05, 2015 10:44 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby Moini » Mon Oct 15, 2018 10:48 pm

Some fonts are not well formed, and Inkscape does not use them as a result. It could be the case here...
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

tylerdurden
Posts: 2184
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Installed Fonts not found in Inkscape 0.92.3

Postby tylerdurden » Tue Oct 16, 2018 12:58 am

Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

tylerdurden
Posts: 2184
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Installed Fonts not found in Inkscape 0.92.3

Postby tylerdurden » Tue Oct 16, 2018 6:15 am

Works in win 8.1 64bit, so could be Inkscape version or Win version.
FF_font.png
FF_font.png (24.94 KiB) Viewed 2091 times



Is this Win10-S?
Was Inkscape downloaded/installed from the Inkscape.org website, or the Win AppStore?
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

Papooch
Posts: 2
Joined: Sun Dec 23, 2018 4:20 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby Papooch » Sun Dec 23, 2018 4:30 am

The problem is (and I'm 100% sure) the new Windows 10 Fall Update. I encountered the same problem and have been unable to solve it. The problem is, that since the last update, newly installed fonts are put into a different directory, namely: C:\Users\<username>\AppData\Local\Microsoft\Windows\Fonts (and you can see that in your screenshot), while previously, they were installed in C:\Windows\Fonts (which you can check for any other font that shows correctly). Until Inkscape reflects this, or adds an option to add custom font directories, I'm afraid we're short of luck :( . The options are to downgrade your Windows or use a virtual machine.

I encountered this problem in Gimp, too, which raised my suspicion that Windows was the culprit. In Gimp, though, one is able to add custom font folders which fixed the problem.

EDIT: If you are the device's administrator, you can right-click the font and select "Install for all users", that will put it into C:\Windows\Fonts. If you are not the admin, thought, you're screwed.

User avatar
brynn
Posts: 10104
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Installed Fonts not found in Inkscape 0.92.3

Postby brynn » Sun Dec 23, 2018 4:14 pm

Interesting. Glad I'm not using Windows 10!

But the op didn't report which system is in use. But hopefully they'll see your message.

Papooch
Posts: 2
Joined: Sun Dec 23, 2018 4:20 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby Papooch » Sun Dec 23, 2018 6:12 pm

They said it was Win 10 and it was posted in October, so I suspect it to be the case.

User avatar
brynn
Posts: 10104
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Installed Fonts not found in Inkscape 0.92.3

Postby brynn » Wed Dec 26, 2018 4:44 am

Oops, my bad. I missed it.

Cantfightcrazy
Posts: 1
Joined: Wed Jan 02, 2019 9:44 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby Cantfightcrazy » Wed Jan 02, 2019 9:50 am

I got it working by right clicking the font file> Install for all users
Didn't see where it was mentioned (if anyone had mentioned it).

Image

KarolM
Posts: 1
Joined: Sat Jan 12, 2019 6:00 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby KarolM » Sat Jan 12, 2019 6:02 am

Cantfightcrazy wrote:I got it working by right clicking the font file> Install for all users
Didn't see where it was mentioned (if anyone had mentioned it).


Thanks a lot, this totally work :)

mrman
Posts: 1
Joined: Tue Jan 15, 2019 2:04 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby mrman » Tue Jan 15, 2019 2:08 am

i right click the installed font and have no option that says install for all users?

Can someone tell me how i can get this up? I'm using windows 10 and have the same issue of my newly installed fonts not showing in inkscape

User avatar
brynn
Posts: 10104
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Installed Fonts not found in Inkscape 0.92.3

Postby brynn » Tue Jan 15, 2019 3:54 pm

If you're on Windows, you might need to have more than one user on the computer, before that option is available.

If you double click on the TTF (or whatever kind of font) file, and click the Install button, does that work? (Or right click > Install)

I'm starting to think we should make a bug report about this?


Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 1 guest