PDF output is slow to render

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
bwelsher
Posts: 2
Joined: Tue Mar 12, 2019 9:59 pm

PDF output is slow to render

Postby bwelsher » Tue Mar 12, 2019 10:21 pm

Hi all, hope this is the right place to ask.
I have created a number of files in Inkscape that, when I save to PDF, render very slowly and progressively when opening in Adobe Reader. They aren't complex files as far as I can see and I am using the default PDF export options (1.5, rasterize 90%, doc page size). I would really appreciate it if someone could spare the time to look at the PDF below and see if they have the same issue and if so what might be the problem in the SVG.
Many thanks
Ben


http://www.mediafire.com/file/1zt7driqn51vaw8/20191201-20191207_BSCU_Phasing_Plan.svg/file
http://www.mediafire.com/file/igw34yca6mkgdc2/20191201-20191207_BSCU_Phasing_Plan.pdf/file

User avatar
brynn
Posts: 10205
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: PDF output is slow to render

Postby brynn » Thu Mar 14, 2019 4:45 am

The PDF also opened progressively for me, but it only took about 2 seconds. That actually is a fairly complex file.

I don't really know if it's normal and expected to open progressively like that, or not. I certainly have seen it before though. But why is it a problem for you? Does it open slower than a couple of seconds for you?

User avatar
druban
Posts: 1717
Joined: Fri Nov 20, 2009 10:48 pm

Re: PDF output is slow to render

Postby druban » Fri Mar 15, 2019 10:16 am

you have more than 250 flowed text objects. Inkscape will convert these to regular text when rendering to PDF which takes a while. Consider using the convert to text command to change all of these to regular text. It saved as pdf and opened the pdf too fast for me to time it. So no more than 0.05 sec each time...
No sectional rendering either.
Hopefully you can uncompress a 7z file. See if this renders to pdf quickly.
Attachments
20191201-20191207 BSCU Phasing Plan.7z
(211.39 KiB) Downloaded 8 times
Your mind is what you think it is.

tylerdurden
Posts: 2240
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: PDF output is slow to render

Postby tylerdurden » Fri Mar 15, 2019 11:33 am

I simply used the "clean document" operation and the exported pdf opens instantly.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

tylerdurden
Posts: 2240
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: PDF output is slow to render

Postby tylerdurden » Sat Mar 16, 2019 9:26 am

Actually, I don't even need to clean the document (I do that reflexively/compulsively).

Just saving a copy as PDF (v1.5, raster=300, doc pagesize) makes a pdf that opens instantly.

I see the OPs svg file is made with Inkscape version .91. The generated pdf shows Cairo version 1.11.2.

Might be good to update to at least .92.2. Cairo image processor has been upgraded to 1.15.6.

Here's the version simply opened in Inkscape .92.2, and saved a copy as pdf.
https://dl.dropbox.com/s/motvbpgnlgsza8 ... oclean.pdf

TD
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

User avatar
druban
Posts: 1717
Joined: Fri Nov 20, 2009 10:48 pm

Re: PDF output is slow to render

Postby druban » Sat Mar 16, 2019 11:26 am

tylerdurden wrote:Actually, I don't even need to clean the document (I do that reflexively/compulsively).


Funny, I did that too without even thinking I don't think it was more than 10 defs though
Your mind is what you think it is.

bwelsher
Posts: 2
Joined: Tue Mar 12, 2019 9:59 pm

Re: PDF output is slow to render

Postby bwelsher » Tue Mar 19, 2019 8:55 pm

Thank you all for your feedback. I think I tried just about all the suggestions without any noticeable improvement but a simple upgrade to 0.92 was what fixed the issue in the end.
Thanks again for the help.


Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 4 guests