inkscape on mac os x

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
jamz

Re: inkscape on mac os x

Postby jamz » Tue Jul 01, 2008 5:37 pm

July 01, 2008
Same problem here! Help please. Using x11 2.2.2 on Leopard 10.5.3

Stokestack

really too bad

Postby Stokestack » Tue Jul 01, 2008 7:34 pm

It's incredible. I've tried every alternative to the abysmal Illustrator I can find on the Mac, but none of them work. NONE. Even after the X11 update and the above instructions, Inkscape just dies after the initial dialog.

Guess I'll have to keep running Corel Draw in a Fusion VM.

The lack of a decent vector-drawing program on the Mac is just incredible.

Stokestack

OK, that works!

Postby Stokestack » Tue Jul 01, 2008 7:45 pm

The clicking-on-opendoc suggestion does work.

Now that I see Inkscape, I realize that the hokey X11 requirement does have a payoff for Mac users: You get a proper menu for this app, in the application's frame where it belongs!

Stokestack

AHA, this works!

Postby Stokestack » Tue Jul 01, 2008 7:49 pm

Advice from the other thread.

After installing the latest X11, right-click Inkscape.app and say "show contents." Go to Contents/Resources. Click on "opendoc". A script should run and eventually you'll get the UI with a blank document.

After that, the whole thing is fixed. You no longer have to launch X11 or anything; just click on the Inkscape icon as you'd expect.

aguarino

Re: inkscape on mac os x

Postby aguarino » Sun Jul 06, 2008 8:22 pm

Very good, this works indeed!!

Thanks a lot

minimac

Re: AHA, this works!

Postby minimac » Mon Jul 07, 2008 12:58 am

Stokestack wrote:Advice from the other thread.

After installing the latest X11, right-click Inkscape.app and say "show contents." Go to Contents/Resources. Click on "opendoc". A script should run and eventually you'll get the UI with a blank document.

After that, the whole thing is fixed. You no longer have to launch X11 or anything; just click on the Inkscape icon as you'd expect.


Many thanks for posting this fix. :D After I ran the opendoc from Contents/Resources, I was able to run Inkscape from the icon. I'm running OS X 10.5.2 (Intel) with X11 2.2.3 (Quartz)

Prior to running opendoc, I kept clicking the Inkscape Icon and would get the pesky popup that talks about the first time Inkscape runs, the font cache would need to be created, but nothing seemed to happen. I had also tried manually launching Inkscape from within X11 xterm by typing /Applications/Inkscape.app/Contents/MacOSX/Inkscape. But that didn't work either. But now, after following your advice and running opendoc, I can run Inkscape just fine from the icon! Thanks again!

Rhael

Re: inkscape mac osx not installing

Postby Rhael » Wed Jul 30, 2008 7:51 pm

Thanks for the tip! No idea what the script does, but it works!

sadielou

Re: inkscape mac osx not installing

Postby sadielou » Sat Aug 02, 2008 10:08 pm

What application should I run openDoc in? (No default is given.) I tried running it in X11, but absolutely nothing happened.
Thanks!

sadielou

Re: inkscape on mac os x

Postby sadielou » Sat Aug 02, 2008 10:12 pm

Thanks, angrytuna! That worked perfectly.

k.

Re: inkscape mac osx not installing

Postby k. » Sun Aug 03, 2008 10:59 am

sadielou wrote:What application should I run openDoc in? (No default is given.) I tried running it in X11, but absolutely nothing happened.
Thanks!


Yeah similar problem, only I don't have x11 because of the problem alfredo mentioned. What do I open it with? I tried AppleScript but it won't work either and tells me there isn't enough information.

User avatar
microUgly
Site Admin
Posts: 2985
Joined: Sat Jun 02, 2007 3:13 pm
Contact:

Re: inkscape mac osx not installing

Postby microUgly » Sun Aug 03, 2008 11:34 am

If you didn't read the Wiki article related to installing Inkscape on a Mac, you might like to. You can find the link in the sticky post.

I'm not a Mac users so I don't know if it has your answer or not.

k.

Re: inkscape mac osx not installing

Postby k. » Sun Aug 03, 2008 10:53 pm

Yeah, I already tried the wiki page. It's just that I don't have my OS X disc 1 for some reason. So I tried to install x11 from the apple site for free, but when I did I had the same problem alfredo mentioned. The program won't let me install it to my hard drive because it says a newer version already exists.

I've tried spotlight searching my entire computer for x11 but it isn't on there, so I'm not sure if the newer software prompt meant I had a compatible but different program on my laptop that functions like x11, but wasn't actually x11.

I also tried the suggestions other users have said about clicking Opendoc, but I'm stuck because it doesn't automatically select a program to run the script. For some folks, it just chooses x11 automatically, but being that I have no x11, I don't know what program to select of the available options. I tried clicking on Applescript (i really don't know much about computers) but it tells me that there isn't enough information, so nothing happens and it closes.

help!

User avatar
sas
Posts: 404
Joined: Sat Oct 06, 2007 5:42 am

Re: inkscape mac osx not installing

Postby sas » Sun Aug 03, 2008 11:37 pm

k. wrote:For some folks, it just chooses x11 automatically, but being that I have no x11, I don't know what program to select of the available options.

There's no point trying to run it if you haven't got X11.

A post by angrytuna suggests getting X11 from http://trac.macosforge.org/projects/xquartz.

k.

Re: inkscape mac osx not installing

Postby k. » Sun Aug 03, 2008 11:44 pm

OK, sorry to keep doing this but I got my hands on an OS X disc and downloaded Xcode. Is this the same thing? When Inkscape asks for X11, Xcode appears as an option, but not x11 itself, so I select it and it doesn't automatically go to inkscape as the others are suggesting. I'm so confused right now getting really frustrated. I've been trying for daaays.

User avatar
sas
Posts: 404
Joined: Sat Oct 06, 2007 5:42 am

Re: inkscape mac osx not installing

Postby sas » Mon Aug 04, 2008 12:47 am

k. wrote:Xcode. Is this the same thing?

No, Xcode is something completely different.

Have you tried XQuartz?

k.

Re: inkscape mac osx not installing

Postby k. » Mon Aug 04, 2008 1:06 am

I don't think I'm eligible. I only have 10.4.11 and I think that's for 10.5 and higher. But somehow I found X11 and downloaded it. It shows up in my utilities as X11, which it's supposed to do. Now my problem is that whenever I click on inkscape in applications it goes directly to X11, and does nothing else from there. I tried closing it and reopening it and nothing changes. I'm stuck staring at X11 and the inkscape icon disappears from my dashboard.

User avatar
sas
Posts: 404
Joined: Sat Oct 06, 2007 5:42 am

Re: inkscape mac osx not installing

Postby sas » Mon Aug 04, 2008 4:53 am

Have you tried dementid's solution now that you've got X11 installed? (Or if that fails, then angrytuna's solution?)

(Edit: fixed a link. Seems to have been broken by an admin merging threads.)
Last edited by sas on Tue Aug 05, 2008 8:07 am, edited 2 times in total.

k.

Re: inkscape mac osx not installing

Postby k. » Mon Aug 04, 2008 1:19 pm

Yeah, sorry if that wasn't clear. I tried the first solution but when I click "Opendoc" it just leads me to X11 but there is no automtic script running I've also tried the angrytuna solution now and this is what happens:

Code: Select all

name$ /Applications/Inkscape.app/Contents/M
acOS/Inkscape
2008-08-03 23:10:16.983 defaults[913]
The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant)
 does not exist
2008-08-03 23:10:17.003 defaults[914]
The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) d
oes not exist
dyld: Library not loaded: /usr/X11R6/lib/libSM.6.dylib
  Referenced from: /Applications/Inkscape.app/Contents/Resources/bin/inkscape-bi
n
  Reason: no suitable image found.  Did find:
        /usr/X11R6/lib/libSM.6.dylib: mach-o, but wrong architecture

ScraPerfect
Posts: 10
Joined: Fri Jul 11, 2008 2:14 am

Re: inkscape mac osx not installing

Postby ScraPerfect » Tue Aug 05, 2008 6:29 am

It used to work and then stopped.. I think I've realized that maybe there was an automatic upgrade which screwed things up. I would boot Inkscape and it would be in the menubar but nothig would happen. When it's correct, X11 is in the menubar but Inscape window is open. I worked for a while last night trying to reinstall inkscape and X11. I found what I had to do was reinstall X11 version 2.2.3 and then do the fix suggested on the wiki. When I downloaded the newest X11 (v 2.3, the code wasn't the same and the fix wouldn't work.) Then I rebooted inkscape and it worked.

http://xquartz.macosforge.org/trac/wiki/X112.3.0

2. Open Terminal.app (in Applications -> Utilities) and type nano /Applications/Inkscape.app/Contents/Resources/script

b. Press CTRL+V (scrolls down a page)

c. Change the code (use the arrows keys to get to the right part) from:
"""
else
# Leopard onwards...

# Warn the user about time-consuming generation of fontconfig caches.
test -d ${HOME}/.fontconfig || exit 12
"""

to:
"""
else
# Leopard onwards...

# Warn the user about time-consuming generation of fontconfig caches.
test -d ${HOME}/.fontconfig
"""

d. Save changes by pressing CTRL+O and then ENTER to confirm

e. Run Inkscape and wait for first-time caching

k.

Re: inkscape on mac os x

Postby k. » Thu Aug 07, 2008 9:17 pm

YES!

I think that was it! I did all that stuff last night, but an automatic upload to x11 happened to be running as well. I never checked it once the download finished, but this morning when i restarted it worked. I wish I had the time to play with it right now....

thanks a LOT!

Prdik

Re: inkscape mac osx not installing

Postby Prdik » Mon Sep 08, 2008 8:55 am

dementid wrote:control click inkscape. Click show contents. Go to resources. Then I just happened to click on a gray folder labeled "opendoc" then some script started running and in less than a minute inkscape opened to a new drawing page. From then was able to open it just by clicking on the inkscape icon. Answered my own question! Hope this helps others.


THAT WORKS GREAT! THANKS!!! PB

mrhatken

Re: inkscape on mac os x

Postby mrhatken » Thu Jan 08, 2009 11:02 pm

Thanks for the tips (opendoc), it gets Inkscape running for me (on OSX 10.5.6).

However, even after that I cannot run directly from the Inkscape icon, it just quits immediately.

Log file shows: "Gtk-WARNING **:cannot open display: local host

I've put export statements in the .profile and .bashrc.

X11 runs fine and so do X11 apps.

I find it strange that opendoc runs fine but Inkscape still has trouble with the display.

Have logged in and out a number of times, tried before and after running X11 and/or opendoc.

Any hints or suggestions (it's been years since I worked with X or even the Unix shell startup files, MacOSX makes this mostly unnecessary, for me at least).

Thanks in advance.

Cheers,
Ashley.

zipe
Posts: 4
Joined: Mon Feb 09, 2009 5:47 pm

Re: inkscape on mac os x

Postby zipe » Wed Feb 11, 2009 6:02 am

thanks a lot for that advise - now i could install inkscape on my macbook (mac os 10.5)

there is only one problem left - it seems there was no folder for inkscape prefernces created (at least i cannot find it). so i have to renew my programm - settings any time i start inkscape. and i cannot edit the preferences.xml which i would like to do, to create some custom dash styles, following this nice tutorial: viewtopic.php?f=6&t=2400

does anybody know, how to create (or maybe just locate......) inkscapes preference files in mac os 10.5?

zipe
Posts: 4
Joined: Mon Feb 09, 2009 5:47 pm

Re: inkscape on mac os x

Postby zipe » Thu Feb 12, 2009 4:15 am

i can answer my own question (due to the help of tomh, who hinted me towards this thread: viewtopic.php?f=22&t=1712):
its hidden, because it starts with a dot. its located user/myname/.inkscape etc and can be found via search, criteria "other","visebility", "file is hidden" or so (i have a german version - "andere","Sichtbarkeit", "Datei ist unsichtbar"), now it shows the folder ".inkscape", inside the folder is the preference.xml (i put a link the sidebar, so i can open it wihout going through the whole procedure).

tbfalsename
Posts: 1
Joined: Tue May 19, 2009 8:46 am

Re: inkscape on mac os x

Postby tbfalsename » Tue May 19, 2009 8:56 am

I'm glad to see other people have managed to get this sorted. I'm using 10.4 and X11 1.1.2
I'm not even getting the Inkscape will take a few minutes message box now.

I've tried the various suggestions I've seen here, the opendoc one asks me what application to open opendoc with.

Trying to run Inkscape from the terminal gives me the following message

Code: Select all

/Applications/Inkscape.app/Contents/MacOS/Inkscape; exit
2009-05-18 23:40:36.488 defaults[769]
The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist
2009-05-18 23:40:36.506 defaults[770]
The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist

(inkscape-bin:737): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Platypus App: PID 737 killed brutally
logout
[Process completed]


I'm going to stick a bug report up later, but first does anyone have any idea how to overcome this?


Mike


Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 5 guests