Inkscape Gets very resource heavy, after using sometime

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
syednayab
Posts: 25
Joined: Thu Jan 27, 2011 10:58 pm
Contact:

Inkscape Gets very resource heavy, after using sometime

Postby syednayab » Thu Jul 28, 2011 4:44 pm

Hi, i find inkscape very simple and inituative, but i have problem after using it 10 or fifteen minutes, it Gets very slow and resource heavy. i am using on windows. Any help.

User avatar
brynn
Posts: 10308
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape Gets very resource heavy, after using sometime

Postby brynn » Thu Jul 28, 2011 7:38 pm

Making full use of layers can help. Then you can turn off layers that you don't need at the moment. Some people like to work in Outline mode (View menu) and/or No Filters mode. Indeed, a large number of nodes, filters, gradients are the usual culprits (a blur is also a filter). You've probably already figured out that working at higher zoom levels also can slow things down.

Other than that, the only solution is increasing the RAM, which is not really a good solution either. This is a known issue, and work is underway (if I understand correctly) to improve it. And again if I understand, it's expected within the next few version upgrades. You could read about it, if you're into the technical side of things, here: http://wiki.inkscape.org/wiki/index.php/Roadmap

Off topic:
No more green on the Inkscape Wiki: http://wiki.inkscape.org/wiki/index.php/Inkscape !

syednayab
Posts: 25
Joined: Thu Jan 27, 2011 10:58 pm
Contact:

Re: Inkscape Gets very resource heavy, after using sometime

Postby syednayab » Fri Jul 29, 2011 4:17 pm

thanks Brynn... Sometime it really get too heavy for 2GB ram!...i will wait till than...Thanks

jkuhl
Posts: 24
Joined: Wed Oct 15, 2008 9:05 am

Re: Inkscape Gets very resource heavy, after using sometime

Postby jkuhl » Thu Oct 06, 2011 2:12 am

At a high level zoom, if you have a lot of blurs and other filters, it gets really slow so if you aren't working on those filters, go to View->Display Mode-> No Filters. This helps immensely when zoomed in very far.

To turn the filters back on, simply go back to Display Mode -> Normal

Other than that, do what Brynn says, make heavy use of layers. For example, if I draw a humanoid, I usually layer things logically, such as Body, Clothes, Head and so on and so forth, which allows me to turn off layers that I am not working on.
http://jkuhl.deviantart.com/
http://jkuhlvectors.blogspot.com/

There is no mastery of a subject, a true master is always training himself to be greater.


Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 4 guests