Inkcut with Roland CAMM-1 GS-24 cutting wrong -> Compiling generates random hops to origin?

Post about using Inkscape with cutters or plotters.
dronelfo
Posts: 2
Joined: Sat Nov 30, 2019 8:55 pm

Inkcut with Roland CAMM-1 GS-24 cutting wrong -> Compiling generates random hops to origin?

Postby dronelfo » Sat Nov 30, 2019 9:06 pm

I run Inkcut on Ubuntu 18.04
inkcut is installed as standalone (but also as inkscape extension does not work)

svg file generated via inkscape is loaded fine and generates a reasonable path to be cut
![Schermade di 2019-11-30 11-49-54](https://user-images.githubusercontent.c ... eb57d1.png)

when I launch the cut via "send to device", the cut is bad.
apparently some some path are included (either in the compiling phase or in the communication phase).
As a matter of fact the blade hops to the origin in unwanted places (the blade is not lifted), cutting through the outlines.
![photo_2019-11-30_11-50-49](https://user-images.githubusercontent.c ... c7e035.jpg)

Thanks for your help

dronelfo
Posts: 2
Joined: Sat Nov 30, 2019 8:55 pm

Inkcut for Roland CAMM-1 GS-24 - CAMM-GL not working - Compiling generates random hops to origin?

Postby dronelfo » Sat Nov 30, 2019 9:23 pm

I run Inkcut on Ubuntu 18.04 and I am working on a Roland CAMM-1 GS-24
I installed inkcut both as standalone and also as inkscape extension, but when i come to cutting neither works perfectly.
In the configuration it start working (not perfectly) if I select HPGL -Hewlett Packard Graphic Language - but when I select CAMM-GL - Roland's Graphic Language it gives error. So I use the HPGL.

On Inkcut, the Svg file generated via inkscape gets loaded fine and inkcut generates a reasonable path to be cut
![Schermade di 2019-11-30 11-49-54](https://user-images.githubusercontent.c ... eb57d1.png)

When I launch the cut via "send to device", the cut is not matching with the preview and it is wrong.
Apparently some some extra path are included (either in the compiling phase or in the communication phase) and as a matter of facts the blade hops to the origin in unwanted places (going some times to the originX, sometimes to OriginY, sometimes both). In this hops, the blade is not lifted and it cutting through the outlines.
![photo_2019-11-30_11-50-49](https://user-images.githubusercontent.c ... c7e035.jpg)

The only hint I found online is this one: viewtopic.php?t=4987&start=25 but I cannot locate the package (and that issue is from almost 10 years ago, it can be that the architecture of the software changed!).

Thanks for your help
Attachments
Schermade di 2019-11-30 11-49-54.png
Schermade di 2019-11-30 11-49-54.png (4.64 KiB) Viewed 114 times
photo_2019-11-30_11-50-49.jpg
photo_2019-11-30_11-50-49.jpg (46.13 KiB) Viewed 114 times

Moini
Posts: 3381
Joined: Mon Oct 05, 2015 10:44 am

Re: Inkcut with Roland CAMM-1 GS-24 cutting wrong -> Compiling generates random hops to origin?

Postby Moini » Tue Dec 03, 2019 3:05 am

Inkcut is a third-party extension, right? Have you asked in the place the author suggests for asking? (whereever you got it from, there may even be multiple sources).
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “Inkscape & Cutters/Plotters”

Who is online

Users browsing this forum: No registered users and 7 guests