Bugs, Issues, and Fixes...Oh My!

Discussion about writing code for Inkscape.
tpatter2
Posts: 3
Joined: Wed Oct 07, 2015 12:14 am

Bugs, Issues, and Fixes...Oh My!

Postby tpatter2 » Wed Oct 07, 2015 12:45 am

Hello Inkscape Community! I'm working with a team of developers that is looking to improve the Inkscape program. Specifically, we're looking for a bug that needs fixing, an issue with speed and performance, or something along that line. I've checked the launchpad bugs on Inkscape but nothing really stood out. Are there any pertinent issues that needs to be worked on?

Lazur
Posts: 4670
Joined: Tue Jun 14, 2016 10:38 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby Lazur » Wed Oct 07, 2015 2:12 am

tpatter2 wrote:Hello Inkscape Community! I'm working with a team of developers that is looking to improve the Inkscape program. Specifically, we're looking for a bug that needs fixing, an issue with speed and performance, or something along that line. I've checked the launchpad bugs on Inkscape but nothing really stood out. Are there any pertinent issues that needs to be worked on?



Welcome aboard!

I would suggest to check out the live chat and ask for/on the development channel.
https://inkscape.org/en/community/discussion/.
Also look up the development mailing list.

Pertinent issues? Depends on definition.
If you use something specific and run into the same bug all the time it can be really annoying.
Like ghosting is an issue that looks an easy task to fix, but probably regular users woud never even see it as a problem.

Then, there is the long requested user coordinate system flipping back and the ability to customize it
-which is, a tough one on compatibility with older svg documents.

tpatter2
Posts: 3
Joined: Wed Oct 07, 2015 12:14 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby tpatter2 » Wed Oct 07, 2015 4:52 am

How much of an issue is the ghosting problem? I wasn't able to replicate the problem on my end through the VM that I'm using.

liamw
Posts: 1
Joined: Wed Oct 07, 2015 5:12 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby liamw » Wed Oct 07, 2015 5:25 am

Here's a quick renderer bug that gets frequently annoying when working with lots of blurs (but is unrelated):

1. Open inkscape, default prefs, new document
2. Draw two overlapping rects
3. Group them
4. Draw a triangular path that intersects the overlap region
5. Clip the group with the path
6. Undo

-->
Image

This broken rendering does not go away until the object is transformed, the page is scrolled outside of the render cache zone, or the document is entirely re-rendered.

User avatar
brynn
Posts: 10205
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Bugs, Issues, and Fixes...Oh My!

Postby brynn » Wed Oct 07, 2015 5:26 am

In order, in my opinion, from a user's perspective:

1 -- The bugs involving the transform attribute. For example, if you try to make a radially tiled clone, in a document which has either had it's orientation switched to Landscape, or any various transforms that might have already taken place in the file (there are many examples, if you search LP), the clones will be sprayed all over the canvas, instead of all in one place. Another issue. In the same type of document which triggers the this bug, using any extension which draws something, it could end up far outside the edges of the screen. Sometimes they are so far outside, that I can't even find them.

(There is a workaround. If you just add a new layer, and work in the layer, these problems are avoided. But imo, it would be nice to have this fixed.)

~suv is our resident bug expert, and I'm sure she can tell you which bug reports are related to this issue, if you would be interested in it. And I'm sure she can suggest what might be urgent issue from the development perspective. (She's one of very few developers who actually pariticpate here. Most of them prefer the mailing list and IRC type of forum.)

2 -- Animation!!! (https://inkscape.org/en/learn/animation/)

User avatar
brynn
Posts: 10205
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Bugs, Issues, and Fixes...Oh My!

Postby brynn » Wed Oct 07, 2015 5:30 am

Welcome liam!

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby ~suv » Wed Oct 07, 2015 6:12 am

brynn wrote:(…) For example, if you try to make a radially tiled clone, in a document which has either had it's orientation switched to Landscape, or any various transforms that might have already taken place in the file (there are many examples, if you search LP), the clones will be sprayed all over the canvas, instead of all in one place.
We already have a fix for that (will be available in the next release), as well as for many other bugs with displaced clones (e.g. when ungrouped or moved to a different layer).
brynn wrote: Another issue. In the same type of document which triggers the this bug, using any extension which draws something, it could end up far outside the edges of the screen. Sometimes they are so far outside, that I can't even find them.
Did you test whatever specific use case / extension you have in mind with a current release? Several known bugs are already fixed - for example those with the perspective and envelope extension since 0.48.3, those with interpolate since 0.48.2, those with DXF export since 0.48.1. Without actual information I can neither look up known bug reports not tell you about the current state.

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby ~suv » Wed Oct 07, 2015 6:40 am

liamw wrote:Here's a quick renderer bug (…)

JFTR - tracked here (at least the variation of releasing the clip instead of undoing it):

Lazur
Posts: 4670
Joined: Tue Jun 14, 2016 10:38 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby Lazur » Wed Oct 07, 2015 7:06 am

tpatter2 wrote:How much of an issue is the ghosting problem? I wasn't able to replicate the problem on my end through the VM that I'm using.


Simplest way is to set the document's background to anything but white, then zoom out to the max, and pan view outside the coloured area. If the object you zoom to is outside, the problem occours.
Even the edge at 80k shows the issue alone.


Another rendering bugs I know of are more related to cairo, like this one.

User avatar
brynn
Posts: 10205
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Bugs, Issues, and Fixes...Oh My!

Postby brynn » Thu Oct 08, 2015 3:59 am

Off topic:
~suv wrote:
brynn wrote: Another issue. In the same type of document which triggers the this bug, using any extension which draws something, it could end up far outside the edges of the screen. Sometimes they are so far outside, that I can't even find them.
Did you test whatever specific use case / extension you have in mind with a current release? Several known bugs are already fixed - for example those with the perspective and envelope extension since 0.48.3, those with interpolate since 0.48.2, those with DXF export since 0.48.1. Without actual information I can neither look up known bug reports not tell you about the current state.


Well, I wasn't asking you (or anyone) to look this up. Just telling this person what I thought was the most annoying bug, as a user. (Anytime I ask Inkscape to draw something, and it ends up not where I expect, I assume it's part of the transform attribute issue or issues. I have not reported them, because I assumed they must be already known.)

I have not specifically done any testing. But whenever I use an extension, (yes in the current release) in the Render submenu, the result is either off the screen (e.g. Random Tree, Spirograph) or centered outside the screen, so that I can only see part of it (e.g. various grids). When I do it on a new layer, it doesn't happen.

If you'd like me to test and report, I'd be happy to :D

(but not here, so as not to hijack the topic)

(I guess the off topic tags must be one of the mods that microUgly mentioned needing to rewrite)

End Off Topic

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby ~suv » Thu Oct 08, 2015 6:56 am

Off topic:
brynn wrote:If you'd like me to test and report, I'd be happy to :D

Thank you for the offer - it's not necessary. I have a fix (work in progress) for those 'Render' extensions which are supposed to create the object starting or centered at the center of the current view and will file a report with details about the proposed changes in the bug tracker (for code review).

User avatar
brynn
Posts: 10205
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Bugs, Issues, and Fixes...Oh My!

Postby brynn » Thu Oct 08, 2015 8:24 am

Thanks :D

tpatter2
Posts: 3
Joined: Wed Oct 07, 2015 12:14 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby tpatter2 » Thu Oct 08, 2015 11:59 pm

I guess I should have been a little more clear for the kind of bugs we're looking for. We're specifically looking for data structure related bugs and issues.

draftman
Posts: 32
Joined: Sun Jan 25, 2015 5:29 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby draftman » Wed Oct 21, 2015 10:00 am

Yes, when I make any changes in Document Properties all extensions run slower.
If I run extensions in default mode (all settings the same as when first down loaded) extensions are almost instantaneous.
If I make any changes they take 2 to 3 seconds to work.
I'm running windows 7, Inkscape .91, 64 bit.
I didn't have this problem in Inkscape .49.

mrusev
Posts: 1
Joined: Wed Dec 13, 2017 8:04 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby mrusev » Wed Dec 13, 2017 8:42 am

Hello guys.
I'm glad to join your community.

1. I can confirm that I have visually the same problem as liamw on Inkscape .92, 64 bit (Win 7).

The problems persists even when I export to PNG.
I usually scroll left and right and zoom in and out a few times and it would eventually render correctly but it is really anoying.

Image

2. I new to it and I'm not sure if it is normal but the whole program seems to run a bit laggy on my machine:

Intel(R) Core(TM) i5 CPU M460 @ 2.53GHz 2.53GHz
NVIDIA GeForce 310M with CUDA / 1GB
8GB DD3 1333 MHz RAM
SSD HDD
Windows 7 64 bit
Inkscape .92, 64 bit

When I scroll thourgh the document I get these render latency trails/artefacts:

Image

After 0.3-0.4 seconds they are resolved when the viewport is redrawn but 1. is very persistent and does not resolve on its own.

Sorry if I'm posting where I'm not supposed to.

Moini
Posts: 3099
Joined: Mon Oct 05, 2015 10:44 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby Moini » Thu Dec 14, 2017 4:46 am

Known issue, I think.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

User avatar
brynn
Posts: 10205
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Bugs, Issues, and Fixes...Oh My!

Postby brynn » Thu Dec 14, 2017 7:47 pm

Might be attributable to large file size. Here's a tutorial which gives some workarounds: https://forum.inkscapecommunity.com/ind ... article=35

Lazur
Posts: 4670
Joined: Tue Jun 14, 2016 10:38 am

Re: Bugs, Issues, and Fixes...Oh My!

Postby Lazur » Thu Dec 14, 2017 10:04 pm

That is a strange issue indeed under regular circumstances.
If you draw over the 80000 px coordinates, the ghosting issue is present on every inkscape version -known bug.
Larger portions can be missing upon different zoom levels, due to caches in the rendering process. Cache settings can be tweaked in the prefereces (Shift+Ctrl+P) though I doubt it will solve the issue as it seems a bit different.


Return to “Programming”

Who is online

Users browsing this forum: No registered users and 3 guests