Snapping issue after 0.48.4 update

Post questions on how to use or achieve an effect in Inkscape.
kmino
Posts: 8
Joined: Wed Jan 23, 2013 9:44 pm

Snapping issue after 0.48.4 update

Postby kmino » Wed Jan 23, 2013 9:57 pm

Hello, I am experiencing an issue after installing the new version.
Snapping objects or groups to guides or grid is not working when moving a selection; when selecting and moving nodes, one or more, snapping works as usual.
Snap-to-objects does not work in any case.
Could it be a problem with my preferences or with the new version?

Thanks in advance

User avatar
brynn
Posts: 10307
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Snapping issue after 0.48.4 update

Postby brynn » Wed Jan 23, 2013 10:22 pm

Image
Welcome to InkscapeForum!

Hhmmm, I was just snapping some guides object centers, and guides to guide intersection, and it worked fine. Aaaannd....yes, I snapped to guide intersections without a problem. But it's probably set for snapping nodes. I rarely have need to snap bounding boxes.

So that we can test under the exact conditions where you've found these issues, please tell us exactly the state of your snap control bar, and also please tell us how you have snapping set in Document Properties > Snap. Screenshots would be find, if you prefer :D

Edit
And also your operating system :D

kmino
Posts: 8
Joined: Wed Jan 23, 2013 9:44 pm

Re: Snapping issue after 0.48.4 update

Postby kmino » Wed Jan 23, 2013 10:58 pm

Thank you for the welcoming and fast answer; actually, I've been using Inkscape since 0.45 and from time to time I experienced some strange snap behavior, but I usually got around it by making a new file (especially when working on large file). Not this time! The only thing that changed was uninstalling 0.48 and installing 0.48.4, and preserving preferences.

Required info:

Document properties, snapping:

Object: Snap closer than 20
Grid: Always snap
Guides: snap closer than 20

Inkscape properties, snapping:

Snap indicator: on
Delay: 150 ms
Closer node thing: on
Weight factor: 0,5
Mouse pointer snap thing: off

Sorry, it is a very lame translation from Italian; is there any other dialog window I should check?
OS is Win7 home premium 64bit

kmino
Posts: 8
Joined: Wed Jan 23, 2013 9:44 pm

Re: Snapping issue after 0.48.4 update

Postby kmino » Wed Jan 23, 2013 11:40 pm

I guess I resolved it myself.
I just realized about the existence of the "snap bar".
I might have absent-mindedly touched and hidden hit :oops:

Thank you anyway!

User avatar
brynn
Posts: 10307
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Snapping issue after 0.48.4 update

Postby brynn » Thu Jan 24, 2013 10:46 pm

Good news Image

Gedep
Posts: 20
Joined: Sat Apr 21, 2012 8:58 pm

Re: Snapping issue after 0.48.4 update

Postby Gedep » Tue Jan 29, 2013 5:06 am

I have the same problem, but I'm unable to resolve it myself.
I re-installed Inkscape as well and snapping to the grid is now not working...

When I draw a circle, snapping is working. It snaps the cursos to the grid and when I click and drag to draw the circle, it snaps as well.
However, when I want to move the circle, it suddenly doesn't snap!

When I draw a line, the same thing. When drawing, snapping works. When moving the line afterwards, It doesn't snap to the grid. When I move individual nodes, snapping to the grid does work.

HELP!

#newbie

Below my snapping settings
Image

User avatar
ragstian
Posts: 1179
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Snapping issue after 0.48.4 update

Postby ragstian » Tue Jan 29, 2013 6:37 am

Hi.

As a circle consists of four nodes, you will need to have some of the snap to nodes, paths or handles enabled.
None of these are enabled in your snap settings.
Be aware that the snapping of circles will only happen at the nodes points (the four quadrants).

If you look closely at your snap bar you will see four horizontal bars, these separates the four major snap types, the first icon below the bar will tell you which snap types are in that section.

Useful reading: http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Snapping.html

RGDS
Ragnar
Last edited by ragstian on Tue Jan 29, 2013 7:49 am, edited 1 time in total.
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

Gedep
Posts: 20
Joined: Sat Apr 21, 2012 8:58 pm

Re: Snapping issue after 0.48.4 update

Postby Gedep » Tue Jan 29, 2013 7:03 am

Thank you for a quick reply!
Problem solved. :-)


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: Google [Bot] and 9 guests