[SOLVED] Can't change interface langugage

Post questions on how to use or achieve an effect in Inkscape.
tengounnombre
Posts: 3
Joined: Thu May 16, 2013 9:01 am

[SOLVED] Can't change interface langugage

Postby tengounnombre » Thu May 16, 2013 10:19 am

Hello, I've been having trouble setting the language in Inkscape. I need it to be in Spanish but it's currently in English.

I have kubuntu 12.04 (KDE 4.8.2). The system language is spanish (everything is displayed in spanish here) and I have installed Inkscape from Synaptic.

I have already tried going to File > Inkscape Preferences... > Interface > Language. At first it was in "System Default" (which should be spanish) so I changed it to "Spanish" with no success.

I already searched in the forum and googled a while, but I found nothing of use.

Any ideas?
Last edited by tengounnombre on Wed May 29, 2013 5:01 am, edited 1 time in total.

User avatar
BobSongs
Posts: 324
Joined: Fri Sep 14, 2007 2:18 pm
Location: Montreal, Canada

Re: Can't change interface langugage

Postby BobSongs » Sat May 18, 2013 2:02 am

Hi and welcome to the InkscapeForum!

[insert welcome sign here]

Might I suggest renaming the settings folder and restarting Inkscape to see if that resolves the issue.

Start the file browser and head to your /home folder. Expose all hidden files and locate the .inkscape folder. Rename it to .inkscape-OLD. Now restart Inkscape. A new .inkscape folder should appear with a fresh set of settings. Should that not fix the language, you may restore your system by shutting Inkscape down, removing .inkscape and renaming .inkscape-OLD to .inkscape.

Let us know if Inkscape itself has a new language interface.

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Can't change interface langugage

Postby ~suv » Sat May 18, 2013 5:46 am

Off topic:
BobSongs wrote:Start the file browser and head to your /home folder. Expose all hidden files and locate the .inkscape folder.

Please do note that since the release of Inkscape 0.47 in 2009 [*], the preferences are saved in '$HOME/.config/inkscape' (in accordance with the XDG Base Directory Specification).

Only older Inkscape versions (<= 0.46) still use the preferences stored in the old location '$HOME/.inkscape'.
Ubuntu 12.04 does offer rather recent Inkscape 0.48.3.1.

-----
[*] See also: Release notes 0.47 > Preferences

tengounnombre
Posts: 3
Joined: Thu May 16, 2013 9:01 am

Re: Can't change interface langugage

Postby tengounnombre » Wed May 22, 2013 9:56 am

Thanks for the reply.
I tried renaming the folder, it didn't solve the problem.
Like ~suv said the folder was actually inside /.config. I changed it there.

tengounnombre
Posts: 3
Joined: Thu May 16, 2013 9:01 am

Re: Can't change interface langugage

Postby tengounnombre » Wed May 29, 2013 5:01 am

I think I found a solution. According to this post (http://blueleaflinux.blogspot.com.ar/2012/12/gimp-e-inkscape-en-espanol-en-kde.html in spanish) there seems to be a problem due to inkscape looking for language preferences in gnome (in spite of having installed kde language pack).

Installing the gnome language pack (sudo apt-get install language-pack-gnome-es) solved the problem.

I don't really know if it's the best solution, but is the only one I found.

Anyway, thanks to BobSongs and ~suv for the help.

User avatar
BobSongs
Posts: 324
Joined: Fri Sep 14, 2007 2:18 pm
Location: Montreal, Canada

Re: Can't change interface langugage

Postby BobSongs » Wed May 29, 2013 5:49 am

tengounnombre wrote:I don't really know if it's the best solution, but is the only one I found.

Anyway, thanks to BobSongs and ~suv for the help.
:D If it works? Then it's a good solution! Also, thank you for posting what you found. This will be of immense value for us if such a question is asked again.

Peace!


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 6 guests