Can't snap to guides

Post questions on how to use or achieve an effect in Inkscape.
olewolf
Posts: 3
Joined: Mon May 25, 2015 9:29 pm

Can't snap to guides

Postby olewolf » Mon May 25, 2015 9:46 pm

I can't figure out how to snap to guides anymore. Apparently others have had similar problems since the introduction of Inkscape 0.91, but the answers seem to reference options that I can't even find anywhere in my Inkscape program. (For example, one answer shows an image of a "cusp" selection icon, which isn't shown in my program.)

I've enabled "Always snap" in the "Snap to guides" section in the document properties windows, and I've created a guide line by dragging it from the ruler. However, when I select the Pencil tool, the edge doesn't snap to anything at all. In fact, it doesn't snap to the grid either although snapping to the grid is enabled, too.

What am I doing wrong? Or perhaps rather, what should I specifically do to draw, e.g., a simple vertical line that snaps to a vertical guide using the Pencil tool?

I'm using Inkscape 0.91 r13725 on a 64-bit Linux (Ubuntu) system.

User avatar
ragstian
Posts: 1181
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Can't snap to guides

Postby ragstian » Mon May 25, 2015 9:50 pm

Hi

Try turning on ALL snap options. If you then get it to snap, turn them off one by one - testing in between until you find the one you need to enable.
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

olewolf
Posts: 3
Joined: Mon May 25, 2015 9:29 pm

Re: Can't snap to guides

Postby olewolf » Mon May 25, 2015 9:56 pm

ragstian wrote:Try turning on ALL snap options. If you then get it to snap, turn them off one by one - testing in between until you find the one you need to enable.

I've tried this already.

However, I just realized that if I create a new drawing, snapping works as expected. I can't make snapping work on an older drawing that I've opened, so I'm inclined to think there's a bug somewhere.

User avatar
ragstian
Posts: 1181
Joined: Thu Oct 11, 2012 2:44 am
Location: Stavanger-Norway

Re: Can't snap to guides

Postby ragstian » Mon May 25, 2015 10:00 pm

Hi.

Can you share the drawing that does not work?
Good Luck!
( ͡° ͜ʖ ͡°)
RGDS
Ragnar

Lazur
Posts: 4715
Joined: Tue Jun 14, 2016 10:38 am

Re: Can't snap to guides

Postby Lazur » Mon May 25, 2015 11:01 pm

Some cases snapping doesn't work if you try to move "too much" object/nodes at once.
Try combining/breaking apart/grouping/ungrouping, some of that may work. (At least on 0.48.)

User avatar
brynn
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Can't snap to guides

Postby brynn » Tue May 26, 2015 12:27 am

Well, it's not generally a good idea to have all the snap options engaged at the same time, because everything will be trying to snap to everything, and you'll have chaos on your canvas, lol.

However, I find the the Pencil tool snaps immediately to a guide, with snapping only engaged, without any specific options engaged (except for Snap to Guides). I'm on Windows, but I haven't heard of any bug on Linux. That doesn't mean there isn't one though. I'm in a bit of a hurry right now, and don't have time. But you could search Launchpad for any potential bugs https://launchpad.net/inkscape

User avatar
Espermaschine
Posts: 892
Joined: Thu Jun 05, 2014 9:10 pm

Re: Can't snap to guides

Postby Espermaschine » Tue May 26, 2015 1:48 am

brynn wrote:Well, it's not generally a good idea to have all the snap options engaged at the same time, because everything will be trying to snap to everything, and you'll have chaos on your canvas, lol.

:lol:
oh i know that one, its very very very annoying :lol:

olewolf
Posts: 3
Joined: Mon May 25, 2015 9:29 pm

Re: Can't snap to guides

Postby olewolf » Tue May 26, 2015 3:43 pm

ragstian wrote:Can you share the drawing that does not work?

Unfortunately no. It contains somewhat sensitive information so I'd rather not share it.

MelM
Posts: 43
Joined: Thu Jan 24, 2013 6:45 pm

Re: Can't snap to guides

Postby MelM » Sat Jul 04, 2015 1:05 pm

I too was having the same issue since recently downloading version 0.91, however, I was able to get it to work if I enabled the smooth node and cusp node snapping. Previously, without those enabled I had set "always snap" in the preferences for guides and that did nothing to help...nothing would snap when nodes are selected. Though objects will snap to the guides when using the select tool to move but only a smooth node will be the one to connect to the guide (and no, the smooth node snapping was NOT enabled). If I disable the "Snap Nodes, Paths and Handles" then I can't enable the cusp or smooth nodes to snap when needed...unless I enable all each time. Hope this is making sense...in other words, the snapping just isn't functioning like it did in previous version (0.48.4) and it's cumbersome at best to have to keep messing with the snapping, which I use a lot.

Does anyone think this issue should go in the Inkscape bug report? Surely I can't be the only one noticing how annoying this is :p

User avatar
brynn
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Can't snap to guides

Postby brynn » Sat Jul 04, 2015 2:57 pm

Well, before making a bug report, it's good to be able to say clearly what the problem is. But as I read through this thread, it's not at all clear.

For the op, it seems like snapping to guides wasn't working for him. When I tested, I didn't have any problems. But I'm on Windows. Maybe there's a Linux issue? What kind of system are you using?

The settings in Document Properties only affect what I call the strength of the snap. If snapping is disabled from the control bar, then snapping isn't going to happen, no matter how you configure it in Doc Prop. Although now that you mention it, I can see how "Always Snap" can be confusing. I would consider making a feature request for better language there.

If I disable the "Snap Nodes, Paths and Handles" then I can't enable the cusp or smooth nodes to snap when needed...unless I enable all each time.

Well, that makes sense. And that's not new. Or maybe I don't understand what you're saying?

It's normal to have to keep re-setting the snap options. As I mentioned earlier in this thread, you can't have them all engaged at the same time, or you can't control anything on the canvas! So you should only have the snap options engaged for the elements you need at the moment, and that means engaging certain buttons and disengaging others, and perhaps at every step you take, in certain situations.

I do think there is at least 1 bug in 0.91 snapping, which I reported: https://bugs.launchpad.net/inkscape/+bug/1443707


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 4 guests