Problem with Render Latex

Post questions on how to use or achieve an effect in Inkscape.
Posts: 1
Joined: Fri Mar 11, 2016 5:14 am

Problem with Render Latex

Postby butscher » Fri Mar 11, 2016 5:22 am


I've installed latex and all the required dependencies needed by Render Latex (and also TexText). I'm using Inkscape 0.91 on Mac OSX ElCapitan. However, when I run Render Latex I receive the following error message:

sh: /usr/local/opt/ghostscript/bin/gs: No such file or directory

PostScript/PDF Interpreter finished. Return status 32512 executed command : /usr/local/opt/ghostscript/bin/gs -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS /var/folders/vr/r692h3_d6w933c7p1x0g3hfm0000gn/T//psinZbw5BY

The interpreter seems to have failed, cannot proceed !

Traceback (most recent call last):
File "", line 160, in <module>
File "/Applications/", line 268, in affect
File "", line 154, in effect
svg_open(self, svg_file)
File "", line 81, in svg_open
doc = inkex.etree.parse(filename)
File "lxml.etree.pyx", line 3299, in lxml.etree.parse (src/lxml/lxml.etree.c:72421)
File "parser.pxi", line 1791, in lxml.etree._parseDocument (src/lxml/lxml.etree.c:105883)
File "parser.pxi", line 1817, in lxml.etree._parseDocumentFromURL (src/lxml/lxml.etree.c:106182)
File "parser.pxi", line 1721, in lxml.etree._parseDocFromFile (src/lxml/lxml.etree.c:105181)
File "parser.pxi", line 1122, in lxml.etree._BaseParser._parseDocFromFile (src/lxml/lxml.etree.c:100131)
File "parser.pxi", line 580, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:94254)
File "parser.pxi", line 690, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:95690)
File "parser.pxi", line 620, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:94757)
lxml.etree.XMLSyntaxError: Document is empty, line 1, column 1

I get a similar message when I run TexText. It's possible that the problem is that /usr/local/opt/ghostscript/bin/gs is on my path somewhere, and of course that directory doesn't exist. My ghostscript is located in /usr/local/bin. I've checked the file /Applications/ and my path there is set correctly. Certainly if I search for /usr/local/opt/ghostscript/bin/gs it does not appear!

Does someone have any suggestions how I should proceed?

Many thanks for your help.

Adrian Butscher

Return to “Help with using Inkscape”

Who is online

Users browsing this forum: meetdilip and 5 guests