Artefacts with calligraphy tool

Post questions on how to use or achieve an effect in Inkscape.
rantonels
Posts: 3
Joined: Mon Jul 17, 2017 6:43 am

Artefacts with calligraphy tool

Postby rantonels » Mon Jul 17, 2017 7:20 am

The Calligraphy tool invariably produces paths with "holes"/"defects"/"artefacts" whenever the pointer moves slowly.

Image

The black stroke on the left is with a mouse, no pressure sensitivity, the red strokes on the right are with a Wacom tablet with pressure sensitivity enabled. All have these faulty paths where the cursor moved more slowly. It just goes crazy, getting all spiky and producing these weird holes.

I have checked that this isn't a problem of the fill rule; these are genuine defects in the paths. The above image is with fill-rule: nonzero - setting fillrule: evenodd creates more white areas where there is self-intersection (which is perfectly normal) but the defects above are not affected, they are actually part of the paths.

I have changed all settings for the Calligraphy tool but this issue persists.

The tablet works very well in general; in particular I don't have this problem with the vector calligraphy tool in Krita.

This makes the tool pretty much unworkable. I'm writing here in case there's something very obvious I'm missing here, and I really hope there is; if not I'll file this as a bug.

I am using Inkscape 0.92.1 r15371 on Ubuntu 17.04.

User avatar
Maestral
Posts: 970
Joined: Sat Aug 27, 2011 7:10 am

Re: Artefacts with calligraphy tool

Postby Maestral » Mon Jul 17, 2017 8:45 am

Your screenshot would be more informative if you had a Calligraphy tool active in that moment. As is, you have the fill rule set to fill the holes but I couldn`t replicate your issue - neither with the tablet nor with the mouse.

The most certain way to check if it is a bug or not might be to draw another stroke and if holes appear, try to change the fill rule. If nothing happens - call ghostbusters ,)
:tool_zoom: <<< click! - but, those with a cheaper tickets should go this way >>> :!:

rantonels
Posts: 3
Joined: Mon Jul 17, 2017 6:43 am

Re: Artefacts with calligraphy tool

Postby rantonels » Mon Jul 17, 2017 8:58 am

I've tried a few combinations and fill rule does not have any effect on these holes (which makes sense as they are in fact genuine errors in the path as I can check with the node tool, so rendering should not really matter), nor do any of the settings of the calligraphy tool.

Moini
Posts: 3317
Joined: Mon Oct 05, 2015 10:44 am

Re: Artefacts with calligraphy tool

Postby Moini » Mon Jul 17, 2017 9:11 am

Perhaps a file would be helpful in this case?
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

Lazur
Posts: 4712
Joined: Tue Jun 14, 2016 10:38 am

Re: Artefacts with calligraphy tool

Postby Lazur » Mon Jul 17, 2017 9:14 am

Can confirm the issue, can recall with fixation and caps set to 0 it's even worse (try to draw a single dot).
Not the random jiggles but the hole-behave sticks out that way.

rantonels
Posts: 3
Joined: Mon Jul 17, 2017 6:43 am

Re: Artefacts with calligraphy tool

Postby rantonels » Mon Jul 17, 2017 9:23 am

I confirm Lazur's comment that a low value for caps exacerbates the issue (but no combination of parameters makes it disappear).

Moini
Posts: 3317
Joined: Mon Oct 05, 2015 10:44 am

Re: Artefacts with calligraphy tool

Postby Moini » Mon Jul 17, 2017 9:25 am

Doesn't appear to be different with 0.91, 0.92.1 or trunk.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

Moini
Posts: 3317
Joined: Mon Oct 05, 2015 10:44 am

Re: Artefacts with calligraphy tool

Postby Moini » Mon Jul 17, 2017 9:26 am

Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

User avatar
Maestral
Posts: 970
Joined: Sat Aug 27, 2011 7:10 am

Re: Artefacts with calligraphy tool

Postby Maestral » Mon Jul 17, 2017 9:48 am

I`ve tried with proposed settings and there is some "noise"
Image
...but when this kind of swift movements is applied - I would not look for a clean look, even on paper.
I still can`t get that many holes, as in the initial post. The orange ones are slow and insecure draws which produced the most resemblance but other than that... ?!
:tool_zoom: <<< click! - but, those with a cheaper tickets should go this way >>> :!:

Moini
Posts: 3317
Joined: Mon Oct 05, 2015 10:44 am

Re: Artefacts with calligraphy tool

Postby Moini » Mon Jul 17, 2017 9:58 am

It seems to depend on the thickness of the line, if I understood the thread correctly (I only skimmed it, though).
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

Lazur
Posts: 4712
Joined: Tue Jun 14, 2016 10:38 am

Re: Artefacts with calligraphy tool

Postby Lazur » Mon Jul 17, 2017 10:11 am

Made a test video here.

"Jiggles" appear mostly when the pulling angle of the pen is close to the angle of the nib and inkscape cannot decide if the next sample should follow the rest in the right or the left side of the "core path".

User avatar
brynn
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Artefacts with calligraphy tool

Postby brynn » Mon Jul 17, 2017 10:07 pm

Using only mouse, I do not have that experience. Even without the Mass setting, I get very little noise. But Mass fixes it for me. I'm using 0.92.1. Windows 7 Pro

Even with pulling in the direction of the nib angle, I can't reproduce it.

ct.png
ct.png (66.17 KiB) Viewed 2913 times

Lazur
Posts: 4712
Joined: Tue Jun 14, 2016 10:38 am

Re: Artefacts with calligraphy tool

Postby Lazur » Mon Jul 17, 2017 11:03 pm

brynn wrote:Even with pulling in the direction of the nib angle, I can't reproduce it.


You already did:

cl1.png
cl1.png (62.44 KiB) Viewed 2899 times


Zoom in so that the width will be larger than the samples used and try pulling the mouse at almost a horizontal direction;
then lower the fixation a tad bit and check again.

Lazur
Posts: 4712
Joined: Tue Jun 14, 2016 10:38 am

Re: Artefacts with calligraphy tool

Postby Lazur » Mon Jul 17, 2017 11:14 pm

With a similar pen setting to the one in the screenshot:
https://www.youtube.com/watch?v=n4QJUKB9YVM&feature=youtu.be

User avatar
brynn
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Artefacts with calligraphy tool

Postby brynn » Tue Jul 18, 2017 7:37 am

Yeah, I saw that. But it's still not as severe as the other reports. I just thought I'd share what I experience, in case it would be helpful.

Back in version 0.46 or 0.45, that was a common experience for me. But I haven't seen it lately.

When I zoom in like you suggest, it slows down my system enough that I can see the artifacts for just a fraction of a 2nd before I release the mouse, and the fill rule setting fills in the gaps.

I can never remember which one is which, but it's this one that's enabled, apparently by default Image (might be related to my tool style - not sure)

I'm not sure why it's so severe for the op, since my experience is so different. I mean, I'm trying hard to create the artifacts, and I can only make one now and then. But the op seems to having it almost constantly - at least that's how I understand the message.

I wonder if there's a preference we're either forgetting about, or don't realize is affecting it. On Calligraphy tool style, there are a couple of unique options at the bottom. Maybe one of those could be involved?

Oh yeah! It seems much worse for me with the absolute units option disabled (unchecked).


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 4 guests