Cannot draw solid line at first

Post questions on how to use or achieve an effect in Inkscape.
AnalogueMan
Posts: 94
Joined: Thu Jan 22, 2015 9:11 pm
Location: Holland (the Netherlands)

Cannot draw solid line at first

Postby AnalogueMan » Thu Oct 11, 2018 10:54 pm

What happend I do not have the foggiest idea but suddenly I cannot draw a solid line in the first attempt using Shift+F6 (Bezier curves and straight lines).
It always now shows as a dashed line at first and I have to modify it into a solid line.
When I look into "Fill and Stroke" all the markers are solid lines but every time I have to change "Dashes" from "Custom" into a solid line.
And then the dashed line changes into a solid one.
I must have unwillingly changed something in the settings but I cannot find what.
Any ideas where to look for?
Analogue man in a digital world

Moini
Posts: 2845
Joined: Mon Oct 05, 2015 10:44 am

Re: Cannot draw solid line at first

Postby Moini » Fri Oct 12, 2018 7:38 am

Double-click on the Bézier tool icon to change its default settings.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

User avatar
brynn
Posts: 9995
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Cannot draw solid line at first

Postby brynn » Sat Oct 13, 2018 12:58 am

This tutorial will explain why that happens, and gives an option to avoid it. https://forum.inkscapecommunity.com/ind ... article=15

Although having said that..... If you changed it to a solid line, it should stay a solid line until you change it again. So I'm not sure why it doesn't stay changed. Not unless after changing to solid, you later changed to dashed again? Hhmmm....

Well I was going to suggest sharing an SVG file with us, but that wouldn't work here..... Ok, if that tutorial doesn't help, let us know. I think we could look at your prefs file to find the problem. Although when I say "we".... Well, I'd be glad to look at it, and try to find the problem. But truthfully, I'm probably not the best choice.

Anyway, let us know :D

AnalogueMan
Posts: 94
Joined: Thu Jan 22, 2015 9:11 pm
Location: Holland (the Netherlands)

Re: Cannot draw solid line at first

Postby AnalogueMan » Sat Oct 13, 2018 4:58 am

Well, thanks for our suggestions!
But the strange thing here is that, after I shut down Inkscape and opened it again, the normal behaviour was back :?
I then (again) checked the prefs for "pen" and I noticed that it was the same as I was facing that strange behaviour and so was
"as usual". See the attachment below. But I will carefully read that link brynn gave me. Perhaps it will shed some light.
Meanwhile, I am glad that it was solved "all by itself" :)
Attachments
Solid-Dashed-line-problem.png
Solid-Dashed-line-problem.png (37.72 KiB) Viewed 395 times
Analogue man in a digital world

Moini
Posts: 2845
Joined: Mon Oct 05, 2015 10:44 am

Re: Cannot draw solid line at first

Postby Moini » Sat Oct 13, 2018 9:13 am

Better don't use 'unset'.

To change: Make a line. Select it. Hold Shift. Click on the black square in the palette at the bottom. Double-click on Bézier tool icon. Click on 'Take from selection'. Now you'll always get a black stroke when you use the Pen tool. This is different from 'unset', which means that it has no color assigned. Inkscape displays an 'unset' stroke as invisible.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 12 guests