Stray Marks in Bitmap Trace

Post questions on how to use or achieve an effect in Inkscape.
rrweather
Posts: 5
Joined: Tue Jan 01, 2019 1:17 am

Stray Marks in Bitmap Trace

Postby rrweather » Tue Jan 01, 2019 1:22 am

Hi Folks,

I am an Inkscape Newb. I am in the process of creating a logo. In the center of the logo is a bitmap trace of a picture of our dog. I cleaned up all the nodes and go the actual facer to look how I want. Once I got the logo created, I noticed stray black lines that I think were from the bitmap trace. I don't know the best way to get rid of these lines. The stray marks are obvious when I export a PNG file. There's 3 marks that I can see. I will attach the PNG file so you can see what I am talking about. Thank you for the help.

Randy
Attachments
DDF.png
DDF.png (46.31 KiB) Viewed 505 times

tylerdurden
Posts: 2239
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Stray Marks in Bitmap Trace

Postby tylerdurden » Tue Jan 01, 2019 5:01 am

I would just use the node tool to select/delete any junk like that.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

rrweather
Posts: 5
Joined: Tue Jan 01, 2019 1:17 am

Re: Stray Marks in Bitmap Trace

Postby rrweather » Wed Jan 02, 2019 4:48 am

Thanks for the reply. I will try again. I was unsuccessful in everything I tried last time. It was like the stray marks didn't exist but then they show up in the final product.

tylerdurden
Posts: 2239
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Stray Marks in Bitmap Trace

Postby tylerdurden » Wed Jan 02, 2019 7:46 am

Presuming the original bitmap has been deleted, I'd look at the screen using menu:view >outlines... See if there are paths there.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

rrweather
Posts: 5
Joined: Tue Jan 01, 2019 1:17 am

Re: Stray Marks in Bitmap Trace

Postby rrweather » Wed Jan 02, 2019 9:53 am

Thanks for the reply. When I view outlines, the marks disappear. The marks are definitely tied to the dog head since they move with it. Perhaps when I traced bitmap, I didn't do something right before I started using it? Again, I am new. I've spent hours reading help messages to get to this point. I'm attaching a png of just the dog head showing the marks. I'd hate to have to start over since the bitmap trace required a lot of tweaks to get to this point. I don't know what else to try. Thanks again.

EDIT: The marks are all along the edge of the image. If I edit nodes, the marks fall right on the lines that connect the nodes. The nodes don't follow the shape of the dog head. Instead, the nodes are forming a square. Not sure if that would matter in any recommended fixes. Thanks for the help.
Attachments
DDF.png
DDF.png (13.51 KiB) Viewed 452 times

rrweather
Posts: 5
Joined: Tue Jan 01, 2019 1:17 am

Re: Stray Marks in Bitmap Trace

Postby rrweather » Wed Jan 02, 2019 10:09 am

Here is a screenshot of what my nodes look like when I edit them on the dog head.
Attachments
Screen Shot 2019-01-01 at 5.07.53 PM.png
Screen Shot 2019-01-01 at 5.07.53 PM.png (119.81 KiB) Viewed 447 times

rrweather
Posts: 5
Joined: Tue Jan 01, 2019 1:17 am

Re: Stray Marks in Bitmap Trace

Postby rrweather » Wed Jan 02, 2019 2:29 pm

Finally figure it out. Ultimately I manually traced the dog head and tweaked it. Then was able to move that back into the logo. Moving it from one file to the other was a bit of a pain because of a setting I didn't know existed. Finally got it to work. I appreciate the help. Thank you.

Randy
Attachments
DDF.png
DDF.png (47.46 KiB) Viewed 439 times

tylerdurden
Posts: 2239
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Stray Marks in Bitmap Trace

Postby tylerdurden » Wed Jan 02, 2019 5:26 pm

You may notice that the trace operation leaves the original bitmap behind the resulting paths. I usually delete that to ensure no extra junk gets in the picture.

You may have also seen that the trace can produce groups and/or stacked paths of varying grayscale (or color).

I'm imagining that there may be an extra layer or group that is making trouble.

Feel free to share the file here or send it via pm if you would like anyone to take a look.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 3 guests