Page 1 of 1

Stray Marks in Bitmap Trace

Posted: Tue Jan 01, 2019 1:22 am
by rrweather
Hi Folks,

I am an Inkscape Newb. I am in the process of creating a logo. In the center of the logo is a bitmap trace of a picture of our dog. I cleaned up all the nodes and go the actual facer to look how I want. Once I got the logo created, I noticed stray black lines that I think were from the bitmap trace. I don't know the best way to get rid of these lines. The stray marks are obvious when I export a PNG file. There's 3 marks that I can see. I will attach the PNG file so you can see what I am talking about. Thank you for the help.

Randy

Re: Stray Marks in Bitmap Trace

Posted: Tue Jan 01, 2019 5:01 am
by tylerdurden
I would just use the node tool to select/delete any junk like that.

Re: Stray Marks in Bitmap Trace

Posted: Wed Jan 02, 2019 4:48 am
by rrweather
Thanks for the reply. I will try again. I was unsuccessful in everything I tried last time. It was like the stray marks didn't exist but then they show up in the final product.

Re: Stray Marks in Bitmap Trace

Posted: Wed Jan 02, 2019 7:46 am
by tylerdurden
Presuming the original bitmap has been deleted, I'd look at the screen using menu:view >outlines... See if there are paths there.

Re: Stray Marks in Bitmap Trace

Posted: Wed Jan 02, 2019 9:53 am
by rrweather
Thanks for the reply. When I view outlines, the marks disappear. The marks are definitely tied to the dog head since they move with it. Perhaps when I traced bitmap, I didn't do something right before I started using it? Again, I am new. I've spent hours reading help messages to get to this point. I'm attaching a png of just the dog head showing the marks. I'd hate to have to start over since the bitmap trace required a lot of tweaks to get to this point. I don't know what else to try. Thanks again.

EDIT: The marks are all along the edge of the image. If I edit nodes, the marks fall right on the lines that connect the nodes. The nodes don't follow the shape of the dog head. Instead, the nodes are forming a square. Not sure if that would matter in any recommended fixes. Thanks for the help.

Re: Stray Marks in Bitmap Trace

Posted: Wed Jan 02, 2019 10:09 am
by rrweather
Here is a screenshot of what my nodes look like when I edit them on the dog head.

Re: Stray Marks in Bitmap Trace

Posted: Wed Jan 02, 2019 2:29 pm
by rrweather
Finally figure it out. Ultimately I manually traced the dog head and tweaked it. Then was able to move that back into the logo. Moving it from one file to the other was a bit of a pain because of a setting I didn't know existed. Finally got it to work. I appreciate the help. Thank you.

Randy

Re: Stray Marks in Bitmap Trace

Posted: Wed Jan 02, 2019 5:26 pm
by tylerdurden
You may notice that the trace operation leaves the original bitmap behind the resulting paths. I usually delete that to ensure no extra junk gets in the picture.

You may have also seen that the trace can produce groups and/or stacked paths of varying grayscale (or color).

I'm imagining that there may be an extra layer or group that is making trouble.

Feel free to share the file here or send it via pm if you would like anyone to take a look.