Cant find the german key...

Post questions on how to use or achieve an effect in Inkscape.

Cant find the german key...

Postby dafassi » Sun May 16, 2010 5:00 am

Hello to all.
My problem is this:

"|, Shift+\ toggle guides and snapping to guides"

Where is this on my german keyboard?

Thanks!
dafassi
 
Posts: 6
Joined: Fri May 14, 2010 5:52 am

Re: Cant find the german key...

Postby prkos » Sun May 16, 2010 5:10 am

Don't you have these marked on your keyboard? Try looking here http://www.forlang.wsu.edu/Images/help/kgerman.gif
just hand over the chocolate and nobody gets hurt

Inkscape Manual on Floss
Inkscape FAQ
very comprehensive Inkscape guide
Inkscape 0.48 Illustrator's Cookbook - 109 recipes to learn and explore Inkscape - with SVG examples to download
User avatar
prkos
 
Posts: 1476
Joined: Tue Nov 06, 2007 8:45 am
Location: Croatia

Re: Cant find the german key...

Postby dafassi » Sun May 16, 2010 5:17 am

I have this marked, but i thought i do something wrong.
Now i think there is a bug?
I used AltGr+"the line right from shift"
and Backslash

nothing happens.

Any idea?
dafassi
 
Posts: 6
Joined: Fri May 14, 2010 5:52 am

Re: Cant find the german key...

Postby dafassi » Sun May 16, 2010 5:48 am

Only works on englisch keyboard :( ... bug?
dafassi
 
Posts: 6
Joined: Fri May 14, 2010 5:52 am

Re: Cant find the german key...

Postby prkos » Sun May 16, 2010 10:32 am

When you type this as text in a text editor does the character appear?

Maybe your AltGr is used by your windows manager so it steals it from Inkscape. Look in Inkscape FAQ to see how you can get Alt key back into Inkscape.
just hand over the chocolate and nobody gets hurt

Inkscape Manual on Floss
Inkscape FAQ
very comprehensive Inkscape guide
Inkscape 0.48 Illustrator's Cookbook - 109 recipes to learn and explore Inkscape - with SVG examples to download
User avatar
prkos
 
Posts: 1476
Joined: Tue Nov 06, 2007 8:45 am
Location: Croatia

Re: Cant find the german key...

Postby ~suv » Sun May 16, 2010 10:24 pm

It is a known issue that some of the default keyboard shortcuts don't work with localized/platform-specific keyboards. The best workaround is to create a custom key-mapping file in the user Inkscape profile with new definitions for those shortcuts that fail because the keys can only be generated in combination with the 'AltGr' (Windows) or 'Option/Alt' (Mac OS X) modifier [1].

steps to create a user keyboard shortcut file:
  1. copy 'share\keys\default.xml' to '%APPDATA%\Inkscape\keys\default-orig.txt' [2]
  2. open the copy 'default-orig.txt', read the introduction in the first part of the file
  3. create a new (plain text) document, add the basic tags needs, copy the shortcut definitions of those listed in 'default-orig.txt' that fail with your keyboard and change the keys so you no longer need the 'AltGr' modifier to invoke the shortcut.
    Here's an example using '*' to show or hide guides:
    Code: Select all
    <?xml version="1.0"?>
    <keys name="Inkscape default">
    <!-- personal keyboard shortcut overrides -->

    <!-- View -->

      <!--
      Note: '*' will no longer invoke the 'star' tool, instead it now toggles guides on and off:
      -->
      <bind key="asterisk" modifiers="Shift" action="ToggleGuides" /> <!-- * -->
      <bind key="asterisk" action="ToggleGuides" display="true"/>

    <!-- don't forget to close the keys tag -->
    </keys>
  4. save the new file as '%APPDATA\Inkscape\keys\default.xml' [2]
  5. restart Inkscape

Shortcut definitions in the user default.xml file will override the default ones. Maybe the details described in an earlier topic will help you (even though they were written for using Inkscape on a Mac): "Previous zoom feature of Grave/Acute Accent"

See also US keyboard layout and German keyboard layout to help you choose new keys.


[1] unfortunately some keyboard shortcuts are hard-coded and can't be remapped.
Bug #165755 in Inkscape: “keys inaccessible with localized/platform-specific keyboards
Bug #266913 in Inkscape: “Text's letter spacing fails with localized keyboard layout
Bug #338302 in Inkscape: “Problem in rotation text using ALT + ]

[2] %APPDATA%\Inkscape\keys depends on your Windows version:
  • Windows XP - C:\Documents and Settings\[USERNAME]\Application Data\Inkscape\keys
  • Windows Vista - C:\Users\[USERNAME]\AppData\Roaming\Inkscape\keys
~suv
 
Posts: 1957
Joined: Sun May 10, 2009 2:07 am

Re: Cant find the german key...

Postby dafassi » Sun May 16, 2010 10:44 pm

Thank you- ill give this a try!
dafassi
 
Posts: 6
Joined: Fri May 14, 2010 5:52 am


Return to Help with using Inkscape

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Google Adsense [Bot], Lazur URH and 10 guests