Node snapping question

Post questions on how to use or achieve an effect in Inkscape.
User avatar
StevenD
Posts: 46
Joined: Sun Feb 24, 2008 12:54 pm
Location: Utah, USA

Node snapping question

Postby StevenD » Fri Mar 14, 2008 2:17 pm

I have node snapping to node set in the document prefs. I have an oval I made with the ellipses tool and made a straight line segment with the pen tool. I can drag a point on the line segment and snap it to any of the four nodes in the oval (even though only three nodes appear). But when I turn the oval into a path using the Object to Path command from the Path menu now I can snap the node of my line segment to only one node in the oval. Why is that.

I'm working in version 0.46.
Last edited by microUgly on Fri Mar 14, 2008 2:33 pm, edited 1 time in total.
Reason: Moved topic. Please read the forum descriptions to help select the correct forum to post your topics in.
StevenD

User avatar
microUgly
Site Admin
Posts: 2985
Joined: Sat Jun 02, 2007 3:13 pm
Contact:

Re: Node snapping question

Postby microUgly » Sat Mar 15, 2008 6:58 am

I can confirm this issue - I'm using 0.46 pre3.

Snapping to node only snaps to end nodes, or nodes that close the shape - this is true even when you manually draw a shape with :tool_pen:. Strangely, if you split a node in your circle, then combine them again you'll be able to snap to it. I suggest logging this as a bug.

dvlierop
Posts: 139
Joined: Sat Sep 08, 2007 4:25 am

Re: Node snapping question

Postby dvlierop » Sun Mar 16, 2008 9:18 pm

No, it's not a bug, it's by design :) ! Inkscape only snaps to non-smooth nodes, and only the end-nodes happen to be non-smooth. For details on this, please have a look at:

http://www.nabble.com/Snapping-to-nodes ... #a15963720

BTW: Only changing the node-type to corner in the node-tool won't help, because it will still be smooth. After changing the type, you will really have to make it non-smooth by dragging the handles.

Regards,

Diederik

dvlierop
Posts: 139
Joined: Sat Sep 08, 2007 4:25 am

Re: Node snapping question

Postby dvlierop » Sun Mar 16, 2008 9:22 pm

What I forgot to mention is that I've been working on the object-snapper the last few days, so the snapping behaviour might depend on exactly which version you're using. I tested it with today's SVN, which is a bit newer than v0.46pre3, but I don't expect any differences for this use case.

Diederik

User avatar
StevenD
Posts: 46
Joined: Sun Feb 24, 2008 12:54 pm
Location: Utah, USA

Re: Node snapping question

Postby StevenD » Mon Mar 17, 2008 12:25 am

:( Bummer man. What do you think the chances are of requesting that it be changed to snap to any kind of node :?:
StevenD

dvlierop
Posts: 139
Joined: Sat Sep 08, 2007 4:25 am

Re: Node snapping question

Postby dvlierop » Thu Mar 20, 2008 7:40 am

It used to be like that, but snapping to smooth nodes can be confusing. I could easily make snapping to smooth nodes optional though, so I'll put that on my TODO list.

User avatar
microUgly
Site Admin
Posts: 2985
Joined: Sat Jun 02, 2007 3:13 pm
Contact:

Re: Node snapping question

Postby microUgly » Thu Mar 20, 2008 8:24 am

dvlierop wrote:It used to be like that, but snapping to smooth nodes can be confusing.

Really? I would have thought it would be the expected behavior by most users since it's still a node. But you've obviously made the change due to feedback. I hesitate to suggest making it an option (too many options can make things more confusing) but if given the choice between one and the other I would go with including an option.


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: Google [Bot] and 10 guests