Error importing .eps

Post questions on how to use or achieve an effect in Inkscape.
drayzen.ocau
Posts: 2
Joined: Mon Feb 28, 2011 12:53 pm

Error importing .eps

Postby drayzen.ocau » Mon Feb 28, 2011 1:31 pm

I tried to submit this as a bug report but the site is broken... :\

----------

Inkscape 0.48.0 r9654
Ghostscript v9.01 w64 (Enabled by '...\bin' and '...lib' added to 'path' System Variable)

Note that my System and User 'temp/tmp' directories are non standard.
('D:\Temp' and 'D:\Temp\User')

Error Window 1:
Inkscape has received additional data from the script executed. The script did not return an error, but this may indicate the results will not be as expected.
Error reading temporary file: [Errno 2] No such file or directory: 'd:\\temp\\user\\tmp4usc0h.svg'

Error Window 2:
Failed to load the requested file F:\Work\Arrow Imports\Koga\Images\2011\Logos\KOGA_REFRESH_2010_BLUE_hi.eps

Inkscape then starts with a blank document.

----------

I'm guessing that my non standard temp(s) are to blame.
Or maybe the temp file is not created as it is not on my system anywhere when the error message is active.
Can someone pass this along to somebody that can fix the problem?

User avatar
brynn
Posts: 10052
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Error importing .eps

Postby brynn » Mon Feb 28, 2011 10:29 pm

Hi drayzen.ocau,
Image
Welcome to InkscapeForum!

What site is broken?

Someone else just reported this exact same error message. I'll be right back with a link to that topic, and you can watch it for developments. I'm not sure if it has any helpful replies yet (besides my welcome).

Edit
Here's that topic: viewtopic.php?f=5&t=8785

drayzen.ocau
Posts: 2
Joined: Mon Feb 28, 2011 12:53 pm

Re: Error importing .eps

Postby drayzen.ocau » Tue Mar 01, 2011 1:32 am

https://bugs.launchpad.net/inkscape

I tried to create a bug report but I keep getting a site error.

User avatar
brynn
Posts: 10052
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Error importing .eps

Postby brynn » Tue Mar 01, 2011 8:37 am

This site (InkscapeForum.com) is only connected to Launchpad by Inkscape. This isn't a developers' forum, although I think a couple of devs do visit from time to time. Anyway, maybe try reporting the error here: https://bugs.launchpad.net/support ??

patrickvhoeijen
Posts: 1
Joined: Fri Apr 08, 2011 5:30 am

Re: Error importing .eps

Postby patrickvhoeijen » Fri Apr 08, 2011 5:32 am

I have same problem importing/opening eps files into Inkscape: I can't find a solution in this topic: could anyone help me?

Patrick.

User avatar
brynn
Posts: 10052
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Error importing .eps

Postby brynn » Sat Apr 09, 2011 8:51 pm

Image
Welcome Patrick!

Since the earlier messages in this topic are confusing, could you please post the error message(s) you're getting, as well as the steps for producing the error?

0netrack
Posts: 1
Joined: Fri Nov 04, 2011 11:21 pm

Re: Error importing .eps

Postby 0netrack » Fri Nov 04, 2011 11:40 pm

I've just managed to solve this problem, and given that I couldn't find the solution anywhere else on the web, thought I better post it here.

I had the same problem as above - Windows 7 64-bit, Ghostscript 9.04 for Windows (64 bit) and Inkscape 0.48, error messages ahoy.

I followed the advice here: http://www.ehow.com/how_5844063_open-_eps-files-inkscape.html, then as it still wasn't working additional advice offering the supposed solution from here: https://bugs.launchpad.net/inkscape/+bug/442243, but i was still getting the message 'Error reading temporary SVG file: [Errno 2]'.

I tried to use ps2pdf in command line to see if it would work, it returned the message 'gswin32c is not recognised' or similar. Which seemed unusal given that I had installed 64-bit gswin64c. After some searching online, I found a reference to this issue here: http://bugs.ghostscript.com/show_bug.cgi?id=692089. Turns out it is a bug with the latest Ghostscript version. Someone refers to 'editing the gssetgs.bat file manually', so I found this file (in gs9.04/lib/ directory) and edited it with notepad. Sure enough, it says the following:

@echo off
@rem $Id$

rem Set default values for GS (gs with graphics window) and GSC
rem (console mode gs) if the user hasn't set them.

if %GS%/==/ set GS=gswin32
if %GSC%/==/ set GSC=gswin32c


So, if you edit it to say this:

@echo off
@rem $Id$

rem Set default values for GS (gs with graphics window) and GSC
rem (console mode gs) if the user hasn't set them.

if %GS%/==/ set GS=gswin64
if %GSC%/==/ set GSC=gswin64c

Then save it (i had some issues as it required an administrator to save, but found if I saved it on the desktop as a .bat file, then copied the file into the directory, it would let me replace the old file).

Bingo - now eps import works fine with inkscape 0.48 :D

Hope this is of use to someone.

inkscapegoat
Posts: 1
Joined: Thu Dec 01, 2011 12:23 am

Re: Error importing .eps

Postby inkscapegoat » Thu Dec 01, 2011 12:27 am

@OneTrack Thanks a ton! You saved the day for me!!! :D :D :D

theevo
Posts: 1
Joined: Wed Feb 08, 2012 9:30 am

Re: Error importing .eps

Postby theevo » Wed Feb 08, 2012 9:33 am

@onetrack THANK YOU. Your solution totally works. 64-bit users rejoice!

ScottMSanders
Posts: 1
Joined: Fri May 04, 2012 5:55 am

Re: Error importing .eps

Postby ScottMSanders » Fri May 11, 2012 5:28 am

This seems fixed now in Ghostscript 9.05 for Windows (64-bit).

anati
Posts: 1
Joined: Mon Jul 16, 2012 3:06 am

Re: Error importing .eps

Postby anati » Mon Jul 16, 2012 3:34 am

hello,

i have trouble with open eps file with inkskape

i have windows vista 32 bit.
inkskape 0.48

i have intsalled Ghostscript 32 bit (gs905w32) (Enabled by '...\bin' and '...lib' added to 'path' System Variable)

when i open the eps file with inskape i don't get error masege,
but i get empty/white page.
it looks like the file is opened, but it is empty

i understand that Ghostscript 9.05 for Windows (64-bit) is fixed.
but i can't install 64-bit on my computer.
is there a solution for the 32-bit version?

hope you can help.

worlock13
Posts: 1
Joined: Mon May 06, 2013 5:37 am

Re: Error importing .eps

Postby worlock13 » Mon May 06, 2013 5:43 am

Thanks guys info was really helpful. Im using Ghostscript 9.07 64bit which gave me this error. Using the info here and on launchpad I figured out that by adding an extra address to the path variable allowed the system to find the missing file

So in plain English you need to add the following text to the end of the path variable

;C:\Program Files\gs\gs9.07\lib;C:\Program Files\gs\gs9.07\bin


remember to change the gs version number to the version of ghostscript your using

aJesusHuman
Posts: 1
Joined: Thu Aug 25, 2016 4:24 am

Re: Error importing .eps

Postby aJesusHuman » Thu Aug 25, 2016 4:27 am

Just registered to thank worlock13. I just used this solution to make things work with GhostScript 9.19 on Windows 10 x64. Inkscape now imports nicely. Thanks!

Darson
Posts: 1
Joined: Sat Oct 15, 2016 8:07 am

Re: Error importing .eps

Postby Darson » Sat Oct 15, 2016 8:24 am

Hi Everyone,

I still can not force Inkscape to import EPS files correctly. EPS loads without an error message as a blank documents

I work on Windows 10 64-bit (regularly updated)

I have installed Ghostscript 9.19 for Windows (64 bit) in the default folder which is C:\Program Files\gs\gs9.19

I have a set system variables: Path:
C:\Program Files\gs\gs9.19\bin;C:\Program Files\gs\gs9.19\lib

What can I do with what tool to use to identify what might be the cause

Please help Darson


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 10 guests