Problems creating a rectangle that my laser cutter treats as a vector

Post about using Inkscape with cutters or plotters.
Posts: 2
Joined: Fri Sep 07, 2018 6:48 am

Problems creating a rectangle that my laser cutter treats as a vector

Postby kzintar » Sat Sep 08, 2018 9:42 am

I'm seeing something strange that I hope someone else has encountered (and can tell me what I'm doing wrong.)

I'm using Inkscape 0.92.2 on two different Macs, both running macOS High Sierra. My laser cutter is a Full Spectrum Laser Muse. The FSL Muse has an embedded webserver that runs a webapp called "RetinaEngrave". RetinaEngrave provides the ability to raster engrave an image and/or laser cut a vector path.

On both Macs I'll create a new document in Inkscape, add a square using the rectangle tool, save the document as an plain SVG, and import the SVG into RetinaEngrave.

When I import the SVG created by the first Mac, RetinaEngrave shows that the square in the SVG has both image and vector components. This is the expected & desired behavior, given that what I need to do is disable the image (raster) engraving and have the Muse cut the square's vector path.

The problem occurs with the SVG created by the second Mac. RetinaEngrave shows in this SVG only has an image component, no vector. This prevents RetinaEngrave from cutting the square's vector path.

I've repeated my tests several times, and believe that I'm using the exact same steps on both Macs to create an SVG containing a square.

I reinstalled Inkscape 0.92.2 on the second Mac, repeated the steps to create an SVG containing a square. Same result; RetinaEngrave only shows the square as an image, not an image & vector.

This suggests that there's a Inkscape preference that persisted with the Inkscape re-install on the second Mac.

But, try as I might, I can't spot anything different in Inkscape's preferences on the first and second Mac.

I suspect that I'm missing something obvious... something in Inkscape's preferences, or in how I'm creating the square using the Rectangle tool, or in how I'm saving the file. I just can't spot what it might be.

Any suggestions or recommendations on what I'm missing or doing wrong? Only using the first Mac (that doesn't have this problem) isn't a viable solution, so I need to figure out what I'm doing wrong.



Posts: 2344
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Problems creating a rectangle that my laser cutter treats as a vector

Postby tylerdurden » Sat Sep 08, 2018 9:42 pm

I'd first delete the preferences.xml in the user profile. It might not have been replaced with the re-installation, since it is in a user-setting location. You can find the location in the Preferences dialog, on the System page.

Close Inkscape, delete the file and restart Inkscape... Inkscape will replace it with the default file when it launches.

Chime back and let us know if that helps or not.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info!

User avatar
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA

Re: Problems creating a rectangle that my laser cutter treats as a vector

Postby brynn » Mon Sep 10, 2018 11:21 am

Or if deleting the preferences.xml file, and letting Inkscape create a default file, doesn't fix it, you could replace it with the prefs file from the computer which is performing properly.

Of course those solutions only help if the problem is because of preferences.

Is there any interface for the RetinaEngrave program on the Macs? Or is that functionality all on the laser machine? If there is an interface on each computer, maybe they have some different settings?

Also, do I understand you're using 2 separate SVG files, which you think are identical? You could try using the same file for both computers. In fact, I might try that before dealing with the preferences.xml files. It might not fit with your workflow, but it would provide diagnostic info, for troubleshooting.

Posts: 3384
Joined: Mon Oct 05, 2015 10:44 am

Re: Problems creating a rectangle that my laser cutter treats as a vector

Postby Moini » Wed Sep 12, 2018 7:14 am

You could also share the files, then we can try to 'spot the (relevant) difference'.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

Posts: 2
Joined: Fri Sep 07, 2018 6:48 am

Re: Problems creating a rectangle that my laser cutter treats as a vector

Postby kzintar » Wed Sep 12, 2018 9:01 am

Thanks for the recommendations!

After I posted my question I continued to experiment with creating squares on both Macs and importing them into RetinaEngrave. I was varying the square's stroke width and color when I noticed a quality of the square that was persisting across relaunches of Inkscape: Stroke opacity

Basically: If the square's stroke opacity isn't 100% then RetinaEngrave doesn't treat the square's strokes as vectors (and won't cut them).

The stoke opacity on the Mac that had problems was 99%.

The stroke opacity on the Mac that didn't have problems was 100%.

I opened my test SVG, did a 'select all', set the stroke opacity to 100%, and saved the SVG. I then imported the SVG into RetinaEngrave... voila'! RetinaEngrave now sees the square's strokes as vectors. Problem solved!

At some point I'll file a bug report with FSL about RetinaEngrave's handling of rectangles with a stroke opacity of 99%. [IMO] RetinaEngrave should either complain about the SVG's structure (if there's something wrong with how Inkscape saves rectangle objects in the SVG, which seems unlikely), or it should warn the user that it can't cut a vector if the stroke opacity is less than 100%.

Lastly... while I'm sure that deleting the preferences XML file would have fixed the problem, if I'd done that I wouldn't have figured out the cause: stroke opacity.

Return to “Inkscape & Cutters/Plotters”

Who is online

Users browsing this forum: No registered users and 6 guests