Installed Fonts not found in Inkscape 0.92.3

This is NOT a support forum. You are welcome to discuss software issues here, but all issues should be reported on Launchpad if you want them fixed.
svorad
Posts: 1
Joined: Wed Jun 26, 2019 4:52 pm

Re: Installed Fonts not found in Inkscape 0.92.3

Postby svorad » Wed Jun 26, 2019 4:55 pm

Alternatively, you can copy the font files into %USERPROFILE%/.fonts
(BTW I had to use a console to create the .fonts directory since explorer choked on the dot notation)

https://bugs.launchpad.net/inkscape/+bug/1416674

jeffhaskin
Posts: 1
Joined: Mon Jul 01, 2019 11:58 pm

Re: Installed Fonts not found in Inkscape 0.92.3

Postby jeffhaskin » Tue Jul 02, 2019 12:01 am

I figured it out!

The reason fonts are now installed in
C:\Users\JeffHaskin\AppData\Local\Microsoft\Windows\Fonts
...instead of
C:\Windows\Fonts
...Is that fonts are now assumed to be user specific. If you right-click on any font you've downloaded and select "Install for all users," the font will appear in C:\Windows\Fonts. You can then close and re-open Inkscape and the font will be there!

cazboen
Posts: 2
Joined: Thu Sep 26, 2019 5:18 pm

Re: Installed Fonts not found in Inkscape 0.92.3

Postby cazboen » Thu Sep 26, 2019 5:19 pm

Hi there, new user here.

I'm also having trouble adding a new font, I've already made sure the new font is inside the Windows\Font folder, but it still won't showup in Inkscape

Moini
Posts: 3349
Joined: Mon Oct 05, 2015 10:44 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby Moini » Sat Sep 28, 2019 9:30 pm

There's an s missing in your path. How did you make the font appear in that folder? Did you restart your computer in between?
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

PACNIA
Posts: 1
Joined: Thu Oct 10, 2019 3:16 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby PACNIA » Thu Oct 10, 2019 3:22 am

I also have this issue, but it can not be resolved by "installing for all users." This is because the font I need in Inkscape is installed via the Microsoft Store. We recently got work computers with Windows 10. There are some documents from our old computers that use the Rockwell font. For font downloads (e.g. those from Google's free library) it is easy to right click the downloaded font file and click "Install for all users" as an admin option. However, the Rockwell Nova font available for free in the Windows Store is listed as an "app," and there is no way to "install for all users" from the Windows Store. The font from the store is not showing up as a file in c:/windows/fonts or the fonts folder in users/name/appdata/..., but it is available for use in Word. How do I get a font that is installed from the Windows Store to be "installed for all users" or to show up in the fonts folders?

Edit: Microsoft helped with getting fonts recognized, by downloading language options for fonts: https://answers.microsoft.com/en-us/win ... 0561658646

Basically, installing the language options for fonts somehow forces it to actually show up in the c:/windows/fonts folder.

tylerdurden
Posts: 2344
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Installed Fonts not found in Inkscape 0.92.3

Postby tylerdurden » Thu Oct 10, 2019 11:38 am

PACNIA wrote:Edit: Microsoft helped with getting fonts recognized, by downloading language options for fonts: https://answers.microsoft.com/en-us/win ... 0561658646

Basically, installing the language options for fonts somehow forces it to actually show up in the c:/windows/fonts folder.


Wow. If this works, this will help a lot of people.

EDIT: this is not working in some cases.
Last edited by tylerdurden on Sat Nov 02, 2019 2:18 am, edited 2 times in total.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

Renee1988
Posts: 1
Joined: Fri Nov 01, 2019 5:41 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby Renee1988 » Fri Nov 01, 2019 5:45 am

I am having the same problem. Is this a problem for a lot of people?

tylerdurden
Posts: 2344
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Installed Fonts not found in Inkscape 0.92.3

Postby tylerdurden » Sat Nov 02, 2019 2:17 am

Yes, Win10 has brought some gremlins.

There are workarounds:
This is something we can't really "fix" in Inkscape, as the list of installed fonts is determined by fontconfig and not by Inkscape itself. Basically this is an upstream bug for fontconfig to support the Windows font registry (I have no idea if this has any chance of ever happening...)
As a workaround we could add that directory manually, but it would still not solve the reports about uninstalled fonts still showing up and font managers not working as I think fontconfig operates purely file based (i.e. every font present in any of the search directories will be offered) whereas the Windows font registry seems to be more complex.
The only "real" fix could have been to re-enable the native pango_win32 back-end (which in fact does support these details as far as I'm aware). Unfortunately after I had it almost working half a year ago this code is now completely broken after recent changes to variable fonts support and Inkscape cannot be compiled with USE_PANGO_WIN32 anymore.

@CZendA could you try to add the line
<dir>~/AppData/Local/Microsoft/Windows/Fonts</dir>
below the line
<dir>WINDOWSFONTDIR</dir>
in the file "...\Inkscape\etc\fonts\fonts.conf" and see if this works as expected and would be an improvement upon the current status?
https://gitlab.com/inkscape/inkscape/is ... _138519712
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

o0a0o
Posts: 1
Joined: Mon Nov 04, 2019 9:05 am

Re: Installed Fonts not found in Inkscape 0.92.3

Postby o0a0o » Mon Nov 04, 2019 9:17 am

For me the trouble with a downloaded font is the file security. So if you download to your "download" folder and install for all users it will install the file in the fonts directory but with limited rights because of its origin (the download folder).
My solution was copying the file to my documents folder and installing it again.
(you can also rightclick the file in the downloads folder and change security permissions)


Return to “Discuss Software Issues”

Who is online

Users browsing this forum: No registered users and 5 guests