Missing font

General discussions about Inkscape.
jkayeh
Posts: 3
Joined: Fri Aug 24, 2018 1:32 pm

Missing font

Postby jkayeh » Fri Aug 24, 2018 1:44 pm

I am struggling with a missing font that does not show up on my list in inkscape. I've read countless similar posts and been pointed to "bugfixes" but I am not sure how to solve the problem. The font is an opentype, saved on my system, unzipped folder, saved in windows font. I am able to use this font in all other programs on my computer. I have uninstalled, reinstalled, open and closed program, turned off/on computer. I have only been using inkscape for the past couple of months so I'm still learning. And I am no computer expert but I know some.
Attachments
deliciously windows clip.JPG
They are present in the windows font folder
deliciously windows clip.JPG (43.79 KiB) Viewed 6948 times
deliciously clip.JPG
Deliciously is showing up on the inkscape list
Deliciously Sans is missing
deliciously clip.JPG (30.59 KiB) Viewed 6948 times

Moini
Posts: 3352
Joined: Mon Oct 05, 2015 10:44 am

Re: Missing font

Postby Moini » Fri Aug 24, 2018 8:37 pm

Not much you can do about it, currently. You could try if it works in the development version of Inkscape, which you can get from here:
https://inkscape.org/releases/master/

Make sure to make a backup of your current preferences file before you run the development version. Preferences files are not backwards compatible.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

tylerdurden
Posts: 2344
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Missing font

Postby tylerdurden » Sat Aug 25, 2018 12:13 am

Might not work in Inkscape regardless of version.

AIUI, Inkscape only will recognize fonts styled with CSS conventions.

Since Inkscape uses SVG as its native file format, we need to take a quick look at how SVG describes font faces. SVG 1.1 (which for fonts is basically the same as CSS 2.1 ) defines the following font-selection properties:
font-family.
font-style: normal, italic, oblique.
font-variant: normal, small-caps.
font-weight: normal, bold, bolder, lighter, 100, 200, 300, 400, 500, 600, 700, 800, 900.
font-stretch: normal, wider, narrower, ultra-condensed, extra-condensed, condensed, semi-condensed, semi-expanded, expanded, extra-expanded, ultra-expanded.

...Also, SVG and CSS have no way to distinguish between two faces in the same font-family that differ in away not described by the above properties (e.g. Pochoir Regular and Pochoir Sprayed).
http://tavmjong.free.fr/blog/?p=822

Renaming the "Preferred Family" to match the font family name using FontForge makes the font usable in Inkscape.
Image
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

jkayeh
Posts: 3
Joined: Fri Aug 24, 2018 1:32 pm

Re: Missing font

Postby jkayeh » Sat Aug 25, 2018 3:22 am

Looks like I'm off to learn how to use FontForge . . . . Thanks for the fix!

cleversomeday
Posts: 62
Joined: Tue Jan 19, 2010 6:52 am

Re: Missing font

Postby cleversomeday » Sat Aug 25, 2018 7:49 am

My workaround is to use Font Lab Pad to generate a quick SVG, but if you want to rename fonts, here's a good tutorial http://themissy.com/2018/font-tutorial- ... ganization

jkayeh
Posts: 3
Joined: Fri Aug 24, 2018 1:32 pm

Re: Missing font

Postby jkayeh » Sat Aug 25, 2018 1:13 pm

I followed tutorials on how to change the name and "family" then finally figured out how to generate and save it properly. But now I get this . . . .
font.JPG
font.JPG (115.42 KiB) Viewed 6846 times

What did I do wrong now?

tylerdurden
Posts: 2344
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: Missing font

Postby tylerdurden » Sun Aug 26, 2018 2:59 am

I can't say what exactly went wrong there, but I'd simply use that font (regular) as it was (from the source). The sans version was the original problem and it does not seem to have the kerning problem the regular version has after processing with FF.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

Chrisjan.j
Posts: 1
Joined: Mon Aug 12, 2019 1:30 am

Re: Missing font

Postby Chrisjan.j » Mon Aug 12, 2019 1:35 am

The easiest solution is to right click on the font when installing, and selecting "install for all users" - rather than double clicking the font to install (which only installs for the active user).

You should be able to install a font for all users even though it is already installed for the current user.

Restart Incskape once the font is installed for all users, and it should work fine.

Dzsulia
Posts: 1
Joined: Sun Aug 25, 2019 5:51 pm

Re: Missing font

Postby Dzsulia » Sun Aug 25, 2019 5:53 pm

You are the best, Chrisjan.j! Thank you for posting your reply, it was the easiest and best solution! :) Worked fine for me!

Moini
Posts: 3352
Joined: Mon Oct 05, 2015 10:44 am

Re: Missing font

Postby Moini » Tue Aug 27, 2019 10:50 am

(Just to clarify: the last two posts here refer to a different issue than the original thread, more info can be found at https://gitlab.com/inkscape/inkscape/issues/50 )
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 3 guests