HOW-TO: Get the ALT key to function properly under Mac OS X

Post questions on how to use or achieve an effect in Inkscape.
Francis North

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Francis North » Sat Jul 25, 2009 10:40 am

Since this solution seems to be addressing not just Inkscape but other X11 apps, I've copied the original HOWTO to my personal blog and will be addressing any further questions and comments from there.

http://francisnorth.blogspot.com/2009/0 ... perly.html

Guest

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Guest » Sat Aug 08, 2009 10:19 am

I still can't kern in flowed text :(

guest

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby guest » Tue Sep 01, 2009 6:12 am

I'm another nedit user who was missing the alt-key menu accelerators. I mapped 66 and 69 to Alt_L and Alt_R respectively, and it works! Thanks.

Mathematical Leopard

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Mathematical Leopard » Sat Oct 10, 2009 1:03 pm

Thanks for such a clearly explained fix :)
For those of you who (like me) couldn't get the commands to work in a Mac OS X Terminal window: you need an xterm window and can open one from within X11 by choosing "Terminal" from the X11 Applications menu.

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby ~suv » Sat Oct 10, 2009 2:15 pm

guest wrote:I'm another nedit user who was missing the alt-key menu accelerators. I mapped 66 and 69 to Alt_L and Alt_R respectively, and it works!
Why both? Now you can't enter any diacritics or special characters into Inkscape's or NEdit's text fields. But those who have a localized keyboard often depend on 'Option+key' combinations for standard characters like '[,],{,},|,\, #' or just the basic '@' and '~'. Keep the right Option-key mapped to 'Mode_switch' and you have both available in any X11-app: 'Alt' and 'Option'.

Mathematical Leopard wrote:For those of you who (like me) couldn't get the commands to work in a Mac OS X Terminal window: you need an xterm window
Care to explain what difficulties you had in Terminal.app?

BTW - JiHO has recently updated the FAQ > Mac OS X specific issues > 'How to make the Alt key work ?'.

Guest(Tim)

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Guest(Tim) » Tue Oct 20, 2009 4:24 pm

I was banging my head against this wall for the past 2 hours or so after watching the video. I did all the proper things in xmodmap but it still wouldn't work. Then I ran across these helpful words in the comments on screencasters.heathenx.org

"In Inkscape 0.46, you have to select all typing, [ go to "text" in the top menu ] and press “Convert to Text” to kern it, even if it’s already in text form.

At least for me."

Gave it a shot. Now I'm kerning like a champ. In the immortal words of Homer Simpson, "Woo-hoo!"

Guest(Tim)

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Guest(Tim) » Tue Oct 20, 2009 4:29 pm

BTW the video I referred to in the first line was an inkscape tutorial on kerning at screencasters.heathenx.org.

Leopard + Inkscape

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Leopard + Inkscape » Mon Nov 23, 2009 4:46 pm

Nicely done, works perfectly. Thank you!

axodys

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby axodys » Sat Dec 05, 2009 6:20 am

Just confirmed that this solution works under Snow Leopard as well. Thanks!

huckfinne

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby huckfinne » Mon Feb 15, 2010 9:55 am

I've done all this and still can't get it to work. Using xev it seems like my alt key is functioning as keycode 66, but in Inkscape nothing happens. I make the .xmodmap file, but I don't think it's loading. When I create the .xinitrc file (The only line is xmodmap ~/.xmodmap), I get X11 in an infinate loop trying to open. That is, the icon pops up in my toolbar, then goes away without opening Inkscape. Then it happens again and again until I kill the process. Any thoughts.

Thanks.


Huck

dcberg

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby dcberg » Wed Mar 17, 2010 11:15 pm

Thanks for the tutorial!
Works great here, with Snow Leopard and the latest development built of Inkscape.

HappyDay

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby HappyDay » Tue Mar 23, 2010 11:23 pm

Thank you very much!
Works great with Snow Leopard Version 10.6.2, XQuartz 2.3.4 und Inkscape 0.47 :D

jco1

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby jco1 » Tue Apr 20, 2010 10:10 pm

Thanks the alt key now works. However when I try to adjust kerning or line spacing of text using alt arrow keys, the arrow keys don't seem to work. To kern I can use alt < > but I haven't worked out how to adjust the line spacing. Any help would be greatly appreciated

Ad

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby Ad » Fri May 07, 2010 12:27 am

sweet, works perfectly fine. took me about 20 minutes though to figure out how to mike the tile sign since i'm working on a swiss keyboard. so if anyone needs to know (should work for all german keyboards): it's alt + n then space.
thanks!

jsn

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby jsn » Tue Sep 14, 2010 9:08 am

Works with Snow Leopard. Thanks.

mascapalabras

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby mascapalabras » Thu Oct 14, 2010 2:27 am

Thanks it works great with snow leopard! :D

unasimple

Re: HOW-TO: Get the ALT key to function properly under Mac OS X

Postby unasimple » Fri Nov 12, 2010 4:55 pm

Just tested under 10.5.8 and inkscape 0.48 works! Thanks you!

youcantoo

Re: HOW-TO: Get the ALT key to function properly under Mac

Postby youcantoo » Sat Dec 25, 2010 9:32 am

Will this solution allow ribbon shortcut functionality to Microsoft Office 2011 for the Mac OS X? In MS Office 2007 and 2010 (PC versions), for example, when you press the alt key, alphanumeric characters appear on the ribbon. I was wondering if this solution you have described above will allow this functionality.

Thanks for your help!

landizzle
Posts: 1
Joined: Sun Feb 13, 2011 3:17 pm

Re: HOW-TO: Get the ALT key to function properly under Mac

Postby landizzle » Sun Feb 13, 2011 3:19 pm

I would just like to say THANK YOU! you're awesome. This issue was really frustrating and your walkthrough was amazing!!!

It didn't work the first time for some reason but when I went to go back and make sure I didn't have a typo, I unchecked all the options in the preferences menu (instead of just the first two like you stated...) it worked!

Thanks, you're my hero of the night!

atg77
Posts: 1
Joined: Tue Dec 13, 2011 6:40 am

Re: HOW-TO: Get the ALT key to function properly under Mac

Postby atg77 » Tue Dec 13, 2011 6:48 am

Sorry for posting to an old thread, but I noticed this is pointed to quite a lot in other postings. There is an easier way, at least in Lion:

1. Switch to the X11 App
2. Choose X11 | Preferences
3. On the Input tab, check the button "Option keys send Alt_L and ALT_R"

And you are done (on Lion, XQuartz 2.6.3, Inkscape 0.48)

Susansa1
Posts: 1
Joined: Tue Jul 30, 2013 12:01 pm

Re: HOW-TO: Get the ALT key to function properly under Mac

Postby Susansa1 » Tue Jul 30, 2013 12:08 pm

Hello, I've read thru this several times and having some problems fixing my ALT key on my MAC OS X 10.6.8 (yes, it's an oldie) when I go to the xterm window there is a code in the box that I can't remove bash-3.2$. Also, where in the xterm window do I type step 4? and I can't locate change the line: keycode 66= etc..) Further clarification please! Thank you - I'm sure it's something simple but I seem to be missing it.


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests