Inkscape Fails to Launch on Mac OSX 10.10.4

General discussions about Inkscape.
matador009
Posts: 3
Joined: Wed Jul 22, 2015 3:46 am

Inkscape Fails to Launch on Mac OSX 10.10.4

Postby matador009 » Wed Jul 22, 2015 3:56 am

I'm new to Inkscape on Mac and I am not able to get it to work. I have installed XQuartz 2.7.7 and Inkscape 0.91.
I have removed and reinstalled both multiple times. Tried launching from within X11 and Console to no avail.

The Inkscape icon shows up on the dock and it bounces for a while but no windows ever show up. I never get prompted for the location of X11. It eventually stops bouncing and it says "Application Not Responding" when you "right-click" on the icon.

Please advice.

Thanks!

User avatar
brynn
Posts: 10308
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby brynn » Wed Jul 22, 2015 5:01 am

I don't use a Mac, so I can't help much. But I thought I would point you to some FAQs, that might help, until one of our Mac users comes along. There are 3 situations here where Inkscape won't run: https://inkscape.org/en/learn/faq/#Mac_ ... fic_issues

If those don't help, I'm sure ~suv will be along pretty soon.

matador009
Posts: 3
Joined: Wed Jul 22, 2015 3:46 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby matador009 » Wed Jul 22, 2015 5:12 am

Thank you but I've seen that article already and it did not help. I should also mention, my problem has nothing to do with Gatekeeper either, I already got that fixed. I've gone through every possible solution I could find online but so far nothing is working.

Thanks for any help that anybody can provide.

User avatar
GAngus
Posts: 82
Joined: Tue Oct 13, 2009 8:41 am
Location: NY

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby GAngus » Wed Jul 22, 2015 11:28 am

I am running 10.10.4 and XQuartz 2.7.7 and have 0.91 installed and it runs just fine.
Just in case it may help, I have the following preferences checked in X11.

Input: only bottom box is checked, Option keys send Alt………..
Output: Millions
Pasteboard: Enable syncing and Update CLIPBOARD when…….. only
Windows: Click through and Focus Follows Mouse …. only
Security: Authenticate connections ….. only

Not sure if this will help or not

matador009
Posts: 3
Joined: Wed Jul 22, 2015 3:46 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby matador009 » Thu Jul 23, 2015 2:04 am

Thanks for the reply but that did not make a difference. Same result, the Inkscape icon just bounces in the dock but nothing ever open and it eventually switches to "Application not responding"

playmeforafool
Posts: 3
Joined: Fri Jul 24, 2015 11:40 pm

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby playmeforafool » Sat Jul 25, 2015 12:50 am

I don't have a solution, just a "me too".

I just got 2 new 13" MacBook Pro's that came with OS 10.10.4 pre-installed. I downloaded Inkscape 0.91 from the Inkscape site, as well as downloaded/installed XQuartz 2.7.7. Both of these new MBP's are exhibiting the same symptoms. When I launch Inkscape, it bounces in the dock for about 2 minutes. It eventually stops bouncing, but the application menu never appears in the menu bar and I have to force quit Inkscape (also, X11 never launches). Same problem even if I launch X11 manually beforehand. I'll try to get over to launchpad and file a report there, along with system log messages.

I also have an older Mac Mini that I previously had Inkscape (0.91/XQuartz 2.7.7) installed on that has been progressively upgraded to OS 10.10.4. Inkscape works perfectly fine there.

playmeforafool
Posts: 3
Joined: Fri Jul 24, 2015 11:40 pm

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby playmeforafool » Sat Jul 25, 2015 4:25 am

I was able to get Inkscape to run by doing the following:

Go to the "System Preferences" and open "Security & Privacy".
On the "General" tab, at the bottom, change the "Allow apps downloaded from:" to the "Anywhere" option.
Start Inkscape. After it has successfully started, go back to the "Security & Privacy" settings and change it back to the default "Mac App Store and identified developers".

Doing this on the 2 MBPs got Inkscape working as expected!

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby ~suv » Sat Jul 25, 2015 5:56 am

playmeforafool wrote:I was able to get Inkscape to run by doing the following: (…)

Thank you for further investigating this issue, and sharing your solution here (as well as in the bug tracker) - this is much appreciated!

Overall, this issue looks like some sort of a regression (or incompatibility) possibly introduced with Apple's latest security update.

oskay
Posts: 6
Joined: Tue Jul 05, 2011 4:50 pm

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby oskay » Sat Jul 25, 2015 11:40 am

You can also *temporarily* override gatekeeper on a mac by selecting the application in the finder, and right-clicking (or control-clicking) on it to bring up the contextual menu. From that contextual menu, select "Open." Then, click "Open" again, in the confirmation dialog box that follows.

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby ~suv » Sat Jul 25, 2015 11:58 am

oskay wrote:You can also *temporarily* override gatekeeper on a mac by selecting the application in the finder, and right-clicking (or control-clicking) on it to bring up the contextual menu. From that contextual menu, select "Open." Then, click "Open" again, in the confirmation dialog box that follows.
Not sure that still works after the latest security updates on systems which never had Inkscape installed before or on Macs with fresh (pre-installed) OS X 10.10.4 (but I cannot verify this myself) - see comments 4-5 in the related bug report (#1478053).

The 'per app' by-passing of Gatekeeper is described in Inkscape's FAQ too, btw.

Hans Dybkjær
Posts: 2
Joined: Sun Feb 08, 2009 9:10 pm

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby Hans Dybkjær » Sun Jul 26, 2015 1:39 am

I was able to get Inkscape to run by doing the following:

Thank you. Had the same problem on new MacBook 12" OS X 10.10.4. Now it works.

playmeforafool
Posts: 3
Joined: Fri Jul 24, 2015 11:40 pm

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby playmeforafool » Thu Jul 30, 2015 4:00 am

oskay wrote:You can also *temporarily* override gatekeeper on a mac by selecting the application in the finder, and right-clicking (or control-clicking) on it to bring up the contextual menu. From that contextual menu, select "Open." Then, click "Open" again, in the confirmation dialog box that follows.


This doesn't seem to work. Again, started with another brand new 13" MBP that came with 10.10.4. I installed Inkscape and XQuartz. When I choose "Open" from the contextual menu, it just launches Inkscape immediately and produces the 2 minutes of bouncing in the dock and then I have to end up force-quitting Inkscape. I never get a 2nd dialogue box asking to "Open" again. So far, the only solution I can find is to temporarily allow applications from any developer as I mentioned above.

marcoconti83
Posts: 1
Joined: Sun Aug 09, 2015 8:12 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby marcoconti83 » Sun Aug 09, 2015 8:19 am

Hi,
I'm a big fan on Inkscape on Windows. But I can't seem to run it on OSX 10.10.4.

XQuartz is installed and I can start it fine. Inkscape 0.91 is installed.
When I launch the Inkscape app, a menu that says "Inkscape" in the OSX bar appears for a second and then it closes.

My OSX is currently set up torun apps from all sources.

I tried looking into the system logs for "Inkscape", and this is what I find:

Code: Select all

09/08/15 00:02:24,429 Finder[315]: There was an error parsing the Info.plist for the bundle at URL Contents/Info.plist -- file:///Applications/Inkscape.app/
 The data couldn’t be read because it isn’t in the correct format.
 <CFBasicHash 0x6100002763c0 [0x7fff75385ed0]>{type = immutable dict, count = 1,
entries =>
   0 : <CFString 0x7fff75350660 [0x7fff75385ed0]>{contents = "NSDebugDescription"} = <CFString 0x610000469440 [0x7fff75385ed0]>{contents = "Cannot parse a NULL or zero-length data"}
}



I tried uninstalling and re-installing, this doesn't fix the problem.

Any suggestion?

tatzl
Posts: 1
Joined: Tue Sep 22, 2015 12:27 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby tatzl » Tue Sep 22, 2015 12:44 am

matador009 wrote:I'm new to Inkscape on Mac and I am not able to get it to work. I have installed XQuartz 2.7.7 and Inkscape 0.91.
I have removed and reinstalled both multiple times. Tried launching from within X11 and Console to no avail.

The Inkscape icon shows up on the dock and it bounces for a while but no windows ever show up. I never get prompted for the location of X11. It eventually stops bouncing and it says "Application Not Responding" when you "right-click" on the icon.

Please advice.

Thanks!


I had the same problem.

After reading this message I tried again to launch Inkscape.

The subsequent trick was successful:

* In the folder "Applications" I opened the package contents
of Inkscape (ctrl click with the mouse)

* In this folder I opened "MacOS"

* Then I did a control click on Inkscape. In the menu
appearing I selected "Open with"

* The application appearing is Terminal, which I
selected. After that Inkscape opened.

I am running MacOS 10.10.5

Tatzl (Thomas)

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby ~suv » Tue Sep 22, 2015 1:06 am

tatzl wrote:
matador009 wrote:I'm new to Inkscape on Mac and I am not able to get it to work. I have installed XQuartz 2.7.7 and Inkscape 0.91.
I have removed and reinstalled both multiple times. Tried launching from within X11 and Console to no avail.

The Inkscape icon shows up on the dock and it bounces for a while but no windows ever show up. I never get prompted for the location of X11. It eventually stops bouncing and it says "Application Not Responding" when you "right-click" on the icon.

I had the same problem.
After reading this message I tried again to launch Inkscape.
The subsequent trick was successful:

<snipped>

I am running MacOS 10.10.5

The recommended solution was posted a few comments higher up, I'll full-quote it again (formatting slightly changed for readability):
playmeforafool wrote:I was able to get Inkscape to run by doing the following:

  1. Go to the "System Preferences" and open "Security & Privacy".
  2. On the "General" tab, at the bottom, change the "Allow apps downloaded from:" to the "Anywhere" option.
  3. Start Inkscape. After it has successfully started, go back to the "Security & Privacy" settings and change it back to the default "Mac App Store and identified developers".

jumpingjax
Posts: 1
Joined: Thu Sep 24, 2015 4:33 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby jumpingjax » Thu Sep 24, 2015 4:35 am

I just downloaded Inkscape today and had a similar problem. Opening it through Terminal worked--allowing all applications under security did not work.

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby ~suv » Thu Sep 24, 2015 6:00 am

jumpingjax wrote:I just downloaded Inkscape today and had a similar problem. Opening it through Terminal worked--allowing all applications under security did not work.

Did you actually follow the instructions step by step? (*)

(*) ... or did you read Gatekeeper and skip the details, thinking "I know how to handle Gatekeeper"?

You'd be the first to report back that the instructions no longer work. Unless this is confirmed independently (e.g. that Apple distributes a brand-new security update and no longer allows to even temporarily disable Gatekeeper completely (i.e. allow apps from Anywhere no longer does what is says)) or e.g. that you work with a Mac maintained in a corporate network which has hardened security settings to the same effect, I'm not fully convinced yet that the instructions are obsolete for any Mac user installing Inkscape for the first time, and I'd be curious to learn more details about what might have changed in recent days (the last time a user (on Yosemite) confirmed on irc that it worked was 4 days ago!).

As explained in earlier messages of this topic, just bypassing Gatekeeper per individual app no longer works for Inkscape (apparently after security updates distributed earlier this year). The user needs to actually disable Gatekeeper temporarily (before launching Inkscape), and revert to default secure settings once Inkscape has launched successfully.

To the best of my knowledge (I went though these steps on irc with Yosemite users several times this summer) the mentioned "trick" (launching the application by accessing files inside the app bundle directly, via Finder or Terminal) is just that, and does not solve the underlying issue (Gatekeeper will still block the app if launched regularly, even if 'spctl' reports that the status of Inkscape.app is "accepted"). The "trick" might be a useful method for debugging (for example it provides easier access to console messages), but it is not a recommendation I would want to see given to regular Inkscape users as steps how to launch Inkscape.app on Macs with recent versions of OS X installed.

Albis
Posts: 1
Joined: Wed Nov 11, 2015 4:26 pm

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby Albis » Wed Nov 11, 2015 4:29 pm

Hi there!
This worked for me too, many thanks guys! ;)


The subsequent trick was successful:

* In the folder "Applications" I opened the package contents
of Inkscape (ctrl click with the mouse)

* In this folder I opened "MacOS"

* Then I did a control click on Inkscape. In the menu
appearing I selected "Open with"

* The application appearing is Terminal, which I
selected. After that Inkscape opened.

I am running MacOS 10.10.5

Tatzl (Thomas)[/quote]

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby ~suv » Wed Nov 11, 2015 7:18 pm

Albis wrote:<snipped>

*sigh* … and another one (favoring a “trick” which does not help as long-time solution over the recommended instructions to disable Gatekeeper (allow from anywhere) for the first launch of Inkscape).

Giving up and unsubscribing from this topic. (JFRT the recommended instructions (which are not a "trick", and which did and and still do work for anyone I recommended them to) can be found here - which is an earlier comment in the same topic, on the same page, just a bit further up).

Moini
Posts: 3309
Joined: Mon Oct 05, 2015 10:44 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby Moini » Thu Nov 12, 2015 12:14 am

Probably they don't realize that you're the one who actually *made* the OSX packages for them, suv ;) - if I could, I'd hand you a nice hot cup of tea now... But you're probably not reading this anyway. Here's one:
tea.png
tea.png (7.36 KiB) Viewed 75402 times
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

~suv
Posts: 2272
Joined: Sun May 10, 2009 2:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby ~suv » Thu Nov 12, 2015 2:17 am

Off topic:
Moini wrote:if I could, I'd hand you a nice hot cup of tea now... But you're probably not reading this anyway.
thx :-) (I still follow new posts via RSS feed - it's just the notifications via mail for this specific topic which I turned off).

… and yes, I had the same thought after my earlier post wrt packaging. I prefer to not add any details to the user profile here though, so I'll try to keep that in mind for future comments/topics.

joshtaylor
Posts: 4
Joined: Tue Nov 17, 2015 10:38 pm
Location: United States
Contact:

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby joshtaylor » Wed Nov 18, 2015 4:40 pm

This is bad news.

turnhalle
Posts: 1
Joined: Tue Aug 30, 2016 5:50 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby turnhalle » Tue Aug 30, 2016 5:54 am

For me this did not work. However if I selected on "Open with" the Quartz Programm (you can find it in the Utilities Folder) it suddenly worked!



Albis wrote:Hi there!
This worked for me too, many thanks guys! ;)


The subsequent trick was successful:

* In the folder "Applications" I opened the package contents
of Inkscape (ctrl click with the mouse)

* In this folder I opened "MacOS"

* Then I did a control click on Inkscape. In the menu
appearing I selected "Open with"

* The application appearing is Terminal, which I
selected. After that Inkscape opened.

I am running MacOS 10.10.5

Tatzl (Thomas)
[/quote]

roystonlodge
Posts: 2
Joined: Fri Mar 21, 2008 1:07 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby roystonlodge » Tue Nov 08, 2016 6:14 am

Just wanted to add my own "me too" response regarding this issue.

I'm running OSX 10.12.1. There is no option in the Security preference to open apps from "anywhere".

superbatfish
Posts: 1
Joined: Thu Jan 12, 2017 6:58 am

Re: Inkscape Fails to Launch on Mac OSX 10.10.4

Postby superbatfish » Thu Jan 12, 2017 7:15 am

Downgrading XQuartz to 2.7.9 fixed the issue for me. (I'm using macOS 10.12 Sierra.)


Return to “General Discussions”

Who is online

Users browsing this forum: No registered users and 0 guests