Inkscape & Windows 10

Using Inkscape with other software? Talk about it here.
ecfallc
Posts: 1
Joined: Sun Aug 30, 2015 1:53 am

Inkscape & Windows 10

Postby ecfallc » Sun Aug 30, 2015 2:02 am

Since upgrading to Windows 10 all of my Inkscape svg files have lost many aspects of the designs. These are company logos, and other drawings that the logo was used in. 80% of the text in the logo is gone. Anyone experiencing the same? Or figured out how to fix this? I have uninstalled and reinstalled, and reverted to the previous version with no luck. Tahnks

User avatar
brynn
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape & Windows 10

Postby brynn » Sun Aug 30, 2015 3:44 am

The problem may have something to do with your preferences. But without knowing details, we would be playing a guessing game. Would you please post a screenshot of what you're supposed to be seeing and what you really see? And if you can, the SVG file would be quite helpful. If you can't post the logo itself, maybe you could make up some kind of sample file, using the same elements, but not the actual logo?

User avatar
z3z
Posts: 36
Joined: Wed Jul 22, 2015 5:03 pm
Location: Scotland

Re: Inkscape & Windows 10

Postby z3z » Tue Sep 01, 2015 12:38 am

Do you have the same fonts installed in Windows 10 that were used when you originally created your logo? Perhaps a font is unavailable and that's causing the hiccup? Having said that, I should have thought Inkscape would substitute a similar font (or the default font, at least) but perhaps that's not happening for some reason.

KaedeKuroi
Posts: 1
Joined: Fri Mar 08, 2019 3:31 am

Re: Inkscape & Windows 10

Postby KaedeKuroi » Fri Mar 08, 2019 3:37 am

You may have to reinstall your fonts. Since one of the latest Windows updates, when installing a font the normal way, it only installs for the current signed in user rather than system wide. You'll need to install it from explorer using right-click>Install for all users. Just be sure you're signed in as an administrator or can sign in as one.

User avatar
brynn
Posts: 10309
Joined: Wed Sep 26, 2007 4:34 pm
Location: western USA
Contact:

Re: Inkscape & Windows 10

Postby brynn » Fri Mar 08, 2019 6:11 am

Actually, recently developers have looked at this problem, and figured out what's causing it. Technically, as far as I can understand it, it's not a problem with Inkscape, but with something which Inkscape uses (made by someone else). As far as I can understand it, the problem is not with the Windows update (although I wouldnl't be surprised if the update is in the chain of events which led to the problem). However, installing system wide does solve the problem.

This is the Issue with the info: https://gitlab.com/inkscape/inkscape/issues/50

If you don't have multiple user accounts on the computer, you have to create another user account, to use this fix. Install for all users doesn't show up as an option until there are at least 2 user accounts on the computer.

Moini
Posts: 3315
Joined: Mon Oct 05, 2015 10:44 am

Re: Inkscape & Windows 10

Postby Moini » Fri Mar 08, 2019 10:37 am

I think in that case, just the option is named differently, from what I read - I remember it said 'install as administrator'.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “Inkscape & other”

Who is online

Users browsing this forum: No registered users and 3 guests