Need Help to install Gears extension. Inkscape v. 0.92.4

Post questions on how to use or achieve an effect in Inkscape.
BretMan
Posts: 14
Joined: Sun Apr 10, 2016 2:37 am

Need Help to install Gears extension. Inkscape v. 0.92.4

Postby BretMan » Sun Oct 06, 2019 10:44 pm

I'm running Windows 10 and Inkscape v. 0.92.4

I need help with installing the Gear creator/generator extension at Extensions>Render>Gear>Gear. It doesn't work by default and I couldn't find any clear instructions anywhere online on what is involved but after an entire day researching the issue and piecing the info. together I found that:

1- First trying to use the Gear extension always results with the error message "The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension.Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml
Technical details:
No module named lxml"
2- Going to those links didn't explain much of anything to me - a novice, but it seems to need "lxml" to be installed. To install lxml you need to have Cython installed but to install Cython you first have to install Python. Those programs don't have easy instructions or installers but the easiest way to install Python is with Chocolatey. So first Chocolatey, then Python, then Cython then lxml. Installing them is all done via the Windows Command Line or Windows Power Shell.
3- They're all installed now and Inkscape shows the lxml in its folders. However, the Gears extension still does not work and I get the same error message above.
What do I need to do to get Gears to finally work?
Thank you

Moini
Posts: 3333
Joined: Mon Oct 05, 2015 10:44 am

Re: Need Help to install Gears extension. Inkscape v. 0.92.4

Postby Moini » Mon Oct 07, 2019 3:35 am

Uninstall Inkscape, remove all traces of it from your hard disk (you can keep your user preferences directory), reinstall.

There are two common causes for this:
- you had an exe of an older Inkscape version installed, and now installed an msi over that or the other way around.
- you had 0.91 installed, uninstalled that, but the uninstaller didn't remove all files.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)

Moini
Posts: 3333
Joined: Mon Oct 05, 2015 10:44 am

Re: Need Help to install Gears extension. Inkscape v. 0.92.4

Postby Moini » Mon Oct 07, 2019 3:36 am

You can remove all that Python stuff you installed. It's not needed at all, Inkscape brings everything it needs for running the Gears extension.
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “Help with using Inkscape”

Who is online

Users browsing this forum: No registered users and 6 guests