transform="translate(0,973.00002) How to always set to default and fix at 0,0 ?

Discuss SVG code, accessible via the XML Editor.
wyatt121
Posts: 18
Joined: Wed Jan 03, 2018 8:15 am

transform="translate(0,973.00002) How to always set to default and fix at 0,0 ?

Postby wyatt121 » Sat Nov 09, 2019 3:37 am

Hi,

This little "transform="translate(0,973.00002)" setting that Inkscape seems to automatically put on the default layer is messing up my world, as it changes the Y-axis, and then Y values within the SVG do not match what is on screen. I realize the Y-axis is flipped also, but this is in addition to the screwy Y world I live in.

I can change it manually in the SVG, but I need to make sure this setting is always set to transform="translate(0,0)

Is there an Inkscape preference to make this happen automatically?

Any help is much appreciated.


Regards,

Wyatt

tylerdurden
Posts: 2344
Joined: Sun Apr 14, 2013 12:04 pm
Location: Michigan, USA

Re: transform="translate(0,973.00002) How to always set to default and fix at 0,0 ?

Postby tylerdurden » Sat Nov 09, 2019 6:34 am

I'd try setting the default SVG file to px as units and scale of 1. I'd also optimize transforms in the Preferences>Behavior>Transforms.
Have a nice day.

I'm using Inkscape 0.92.2 (5c3e80d, 2017-08-06), 64 bit win8.1

The Inkscape manual has lots of helpful info! http://tavmjong.free.fr/INKSCAPE/MANUAL/html/

User avatar
druban
Posts: 1915
Joined: Fri Nov 20, 2009 10:48 pm

Re: transform="translate(0,973.00002) How to always set to default and fix at 0,0 ?

Postby druban » Sat Nov 09, 2019 8:08 am

Save the corrected file as default.svg in your user folder and that's going to be the starting file from now on
Your mind is what you think it is.

wyatt121
Posts: 18
Joined: Wed Jan 03, 2018 8:15 am

Re: transform="translate(0,973.00002) How to always set to default and fix at 0,0 ?

Postby wyatt121 » Sat Nov 09, 2019 11:19 am

Great! Thank you guys for your help. -- Wyatt

Moini
Posts: 3352
Joined: Mon Oct 05, 2015 10:44 am

Re: transform="translate(0,973.00002) How to always set to default and fix at 0,0 ?

Postby Moini » Sat Nov 09, 2019 11:47 am

There's no such default transformation for me, nor does that exist in any of the default svg files for the various languages for Inkscape 0.92.4.

How did you create the default layer that you have there? Is it a custom (default) template? Have you ever resized the image? What's your Inkscape version?
Something doesn't work? - Keeping an eye on the status bar can save you a lot of time!

Inkscape FAQ - Learning Resources - Website with tutorials (German and English)


Return to “SVG / XML Code”

Who is online

Users browsing this forum: No registered users and 1 guest